Subversion Repositories liboop-bad

Compare Revisions

Ignore whitespace Rev 41 → Rev 42

/trunk/debian/rules
1,12 → 1,9
#!/usr/bin/make -f
# debian/rules file for libraries
#
# To build the packages, run `dpkg-buildpackage' or `debuild' from the
# parent directory of this file. (You may need to specify the `-rfakeroot'
# option if you are using dpkg-buildpackage and are not running as root)
#
# $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $
#
# Copyright (C) 1999, 2000, 2001, 2002 Timshel Knoll <timshel@debian.org>
# Licensed under the terms of the GNU General Public License
#
21,14 → 18,13
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 
CFLAGS += -g
ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS)))
CFLAGS += -O2
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
buildflags := --build=$(DEB_BUILD_GNU_TYPE)
else
CFLAGS += -O0
buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
 
buildflags += $(shell dpkg-buildflags --export=configure)
 
# The name of the library - this is the base name of the packages that
# will be built
86,15 → 82,16
configure-stamp:
dh_testdir
 
autoreconf -sfi
[ -f debian/autoreconf.before ] || dh_autoreconf
 
env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
./configure --prefix=/usr $(buildflags)
 
touch $@
 
build: configure-stamp build-stamp
build-stamp:
build: build-arch
build-indep:
build-arch: build-stamp
build-stamp: configure-stamp
dh_testdir
 
$(MAKE)
108,8 → 105,8
 
[ ! -f Makefile ] || $(MAKE) distclean
 
rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh
dh_clean
dh_autoreconf_clean
dh_clean libtool configure
 
install: build
dh_testdir