Rev 43 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 43 | Rev 63 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # |
2 | # |
3 | # To build the packages, run `dpkg-buildpackage' or `debuild' from the |
3 | # To build the packages, run `dpkg-buildpackage' or `debuild' from the |
4 | # parent directory of this file. (You may need to specify the `-rfakeroot' |
4 | # parent directory of this file. (You may need to specify the `-rfakeroot' |
5 | # option if you are using dpkg-buildpackage and are not running as root) |
5 | # option if you are using dpkg-buildpackage and are not running as root) |
6 | # |
6 | # |
7 | # Copyright © 1999, 2000, 2001, 2002 Timshel Knoll <timshel@debian.org> |
7 | # Copyright © 1999, 2000, 2001, 2002 Timshel Knoll <timshel@debian.org> |
8 | # Copyright © 2008, 2009, 2010, 2012 Magnus Holmgren <holmgren@debian.org> |
8 | # Copyright © 2008, 2009, 2010, 2012 Magnus Holmgren <holmgren@debian.org> |
9 | # Licensed under the terms of the GNU General Public License |
9 | # Licensed under the terms of the GNU General Public License |
10 | # |
10 | # |
11 | # Based originally on Sample debian/rules that uses debhelper, from dh-make, |
11 | # Based originally on Sample debian/rules that uses debhelper, from dh-make, |
12 | # GNU copyright 1997 to 1999 by Joey Hess. |
12 | # GNU copyright 1997 to 1999 by Joey Hess. |
13 | 13 | ||
14 | # Uncomment this to turn on verbose mode. |
14 | # Uncomment this to turn on verbose mode. |
15 | #export DH_VERBOSE=1 |
15 | #export DH_VERBOSE=1 |
16 | 16 | ||
17 | # These are used for cross-compiling and for saving the configure script |
17 | # These are used for cross-compiling and for saving the configure script |
18 | # from having to guess our platform (since we know it already) |
18 | # from having to guess our platform (since we know it already) |
19 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
19 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
20 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
20 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
21 | 21 | ||
22 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
22 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
23 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
23 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
24 | else |
24 | else |
25 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
25 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
26 | endif |
26 | endif |
27 | 27 | ||
28 | buildflags += $(shell dpkg-buildflags --export=configure) |
28 | buildflags += $(shell dpkg-buildflags --export=configure) |
29 | 29 | ||
30 | configure: configure-stamp |
30 | configure: configure-stamp |
31 | configure-stamp: |
31 | configure-stamp: |
32 | dh_testdir |
32 | dh_testdir |
33 | 33 | ||
34 | [ -f debian/autoreconf.before ] || dh_autoreconf |
34 | [ -f debian/autoreconf.before ] || dh_autoreconf |
35 | 35 | ||
36 | ./configure --prefix=/usr $(buildflags) |
36 | ./configure --prefix=/usr $(buildflags) |
37 | 37 | ||
38 | touch $@ |
38 | touch $@ |
39 | 39 | ||
40 | build: build-arch |
40 | build: build-arch |
41 | build-indep: |
41 | build-indep: |
42 | build-arch: build-stamp |
42 | build-arch: build-stamp |
43 | build-stamp: configure-stamp |
43 | build-stamp: configure-stamp |
44 | dh_testdir |
44 | dh_testdir |
45 | 45 | ||
46 | $(MAKE) |
46 | $(MAKE) |
47 | 47 | ||
48 | touch $@ |
48 | touch $@ |
49 | 49 | ||
50 | clean: |
50 | clean: |
51 | dh_testdir |
51 | dh_testdir |
52 | dh_testroot |
52 | dh_testroot |
53 | rm -f build-stamp configure-stamp |
53 | rm -f build-stamp configure-stamp |
54 | 54 | ||
55 | [ ! -f Makefile ] || $(MAKE) distclean |
55 | [ ! -f Makefile ] || $(MAKE) distclean |
56 | 56 | ||
57 | dh_autoreconf_clean |
57 | dh_autoreconf_clean |
58 | dh_clean |
58 | dh_clean |
59 | 59 | ||
60 | install: build |
60 | install: build |
61 | dh_testdir |
61 | dh_testdir |
62 | dh_testroot |
62 | dh_testroot |
63 | dh_prep |
63 | dh_prep |
64 | 64 | ||
65 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
65 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
66 | 66 | ||
67 | binary-indep: |
67 | binary-indep: |
68 | dh_testdir |
68 | dh_testdir |
69 | dh_testroot |
69 | dh_testroot |
70 | dh_install -i |
70 | dh_install -i |
71 | 71 | ||
72 | dh_installdocs -i |
72 | dh_installdocs -i |
73 | dh_installman -i |
73 | dh_installman -i |
74 | dh_installinfo -i |
74 | dh_installinfo -i |
75 | dh_installchangelogs -i |
75 | dh_installchangelogs -i |
76 | dh_link -i |
76 | dh_link -i |
77 | dh_compress -i -Xliboop-doc/html |
77 | dh_compress -i -Xliboop-doc/html |
78 | dh_fixperms -i |
78 | dh_fixperms -i |
79 | dh_installdeb -i |
79 | dh_installdeb -i |
80 | dh_gencontrol -i |
80 | dh_gencontrol -i |
81 | dh_md5sums -i |
81 | dh_md5sums -i |
82 | dh_builddeb -i |
82 | dh_builddeb -i |
83 | 83 | ||
84 | binary-arch: install |
84 | binary-arch: install |
85 | dh_testdir |
85 | dh_testdir |
86 | dh_testroot |
86 | dh_testroot |
87 | dh_install -a |
87 | dh_install -a |
88 | 88 | ||
89 | dh_installdocs -a |
89 | dh_installdocs -a |
90 | dh_installman -a |
90 | dh_installman -a |
91 | dh_installinfo -a |
91 | dh_installinfo -a |
92 | dh_installchangelogs -a |
92 | dh_installchangelogs -a |
93 | dh_link -a |
93 | dh_link -a |
94 | dh_strip -a --dbg-package=liboop-dbg |
94 | dh_strip -a --dbgsym-migration='liboop-dbg (<< 1.0.1-2~)' |
95 | dh_compress -a -Xliboop-doc/html |
95 | dh_compress -a -Xliboop-doc/html |
96 | dh_fixperms -a |
96 | dh_fixperms -a |
97 | dh_makeshlibs -a |
97 | dh_makeshlibs -a |
98 | dh_installdeb -a |
98 | dh_installdeb -a |
99 | # Don't add the depends for adapter libraries - programs which link |
99 | # Don't add the depends for adapter libraries - programs which link |
100 | # with them will also link with the appropriate library |
100 | # with them will also link with the appropriate library |
101 | dh_shlibdeps -a -Xliboop- |
101 | dh_shlibdeps -a -Xliboop- |
102 | dh_gencontrol -a |
102 | dh_gencontrol -a |
103 | dh_md5sums -a |
103 | dh_md5sums -a |
104 | dh_builddeb -a |
104 | dh_builddeb -a |
105 | 105 | ||
106 | binary: binary-indep binary-arch |
106 | binary: binary-indep binary-arch |
107 | 107 | ||
108 | .PHONY: configure build build-arch build-indep install |
108 | .PHONY: configure build build-arch build-indep install |
109 | .PHONY: binary-indep binary-arch binary clean |
109 | .PHONY: binary-indep binary-arch binary clean |