Rev 86 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 86 | Rev 101 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | 2 | ||
3 | SOURCE_PACKAGE = libspf2 |
3 | SOURCE_PACKAGE = libspf2 |
4 | LIB_PACKAGE = libspf2-2 |
4 | LIB_PACKAGE = libspf2-2 |
5 | 5 | ||
6 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
6 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
7 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
7 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
8 | 8 | ||
9 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
9 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
10 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
10 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
11 | else |
11 | else |
12 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
12 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
13 | endif |
13 | endif |
14 | 14 | ||
15 | CFLAGS := $(shell dpkg-buildflags --get CFLAGS) |
15 | CFLAGS := $(shell dpkg-buildflags --get CFLAGS) |
16 | CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS) |
16 | CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS) |
17 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
17 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
18 | perlld := $(shell perl -MConfig -e 'print $$Config{ld}') |
18 | perlld := $(shell perl -MConfig -e 'print $$Config{ld}') |
19 | 19 | ||
20 | DEB_LDFLAGS_MAINT_APPEND = -Wl,--version-script=$(CURDIR)/debian/libspf2.ver |
20 | DEB_LDFLAGS_MAINT_APPEND = -Wl,--version-script=$(CURDIR)/debian/libspf2.ver |
21 | buildflags += $(shell DEB_LDFLAGS_MAINT_APPEND="$(DEB_LDFLAGS_MAINT_APPEND)" \ |
21 | buildflags += $(shell DEB_LDFLAGS_MAINT_APPEND="$(DEB_LDFLAGS_MAINT_APPEND)" \ |
22 | dpkg-buildflags --export=configure) |
22 | dpkg-buildflags --export=configure) |
23 | 23 | ||
24 | config.status: configure |
24 | config.status: configure |
25 | dh_testdir |
25 | dh_testdir |
26 | # Add here commands to configure the package. |
26 | # Add here commands to configure the package. |
27 | dh_autoreconf |
27 | dh_autoreconf |
28 | ./configure --prefix=/usr $(buildflags) |
28 | ./configure --prefix=/usr $(buildflags) |
29 | 29 | ||
30 | build: build-arch |
30 | build: build-arch |
31 | build-indep: |
31 | build-indep: |
32 | build-arch: build-arch-stamp |
32 | build-arch: build-arch-stamp |
33 | build-arch-stamp: config.status |
33 | build-arch-stamp: config.status |
34 | dh_testdir |
34 | dh_testdir |
35 | 35 | ||
36 | $(MAKE) |
36 | $(MAKE) |
37 | cd perl && perl Makefile.PL INSTALLDIRS=vendor \ |
37 | cd perl && perl Makefile.PL INSTALLDIRS=vendor \ |
38 | OPTIMIZE="$(CPPFLAGS) $(CFLAGS)" LD="$(perlld) $(CFLAGS) $(LDFLAGS)" |
38 | OPTIMIZE="$(CPPFLAGS) $(CFLAGS)" LD="$(perlld) $(CFLAGS) $(LDFLAGS)" |
39 | $(MAKE) -C perl LD_RUN_PATH= |
39 | $(MAKE) -C perl LD_RUN_PATH= |
40 | 40 | ||
41 | touch "$@" |
41 | touch "$@" |
42 | 42 | ||
43 | clean: |
43 | clean: |
44 | dh_testdir |
44 | dh_testdir |
45 | dh_testroot |
45 | dh_testroot |
46 | rm -f build-arch-stamp |
46 | rm -f build-arch-stamp |
47 | 47 | ||
48 | [ ! -f Makefile ] || $(MAKE) distclean |
48 | [ ! -f Makefile ] || $(MAKE) distclean |
49 | [ ! -f perl/Makefile ] || $(MAKE) -C perl realclean |
49 | [ ! -f perl/Makefile ] || $(MAKE) -C perl realclean |
50 | 50 | ||
51 | dh_autoreconf_clean |
51 | dh_autoreconf_clean |
52 | dh_clean |
52 | dh_clean |
53 | 53 | ||
54 | install: build-arch |
54 | install: build-arch |
55 | dh_testdir |
55 | dh_testdir |
56 | dh_testroot |
56 | dh_testroot |
57 | dh_prep |
57 | dh_prep |
58 | 58 | ||
59 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
59 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
60 | $(MAKE) -C perl install DESTDIR=$(CURDIR)/debian/tmp |
60 | $(MAKE) -C perl install DESTDIR=$(CURDIR)/debian/tmp |
61 | 61 | ||
62 | binary-arch: install |
62 | binary-arch: install |
63 | dh_testdir |
63 | dh_testdir |
64 | dh_testroot |
64 | dh_testroot |
65 | dh_install -a |
65 | dh_install -a |
66 | # Rename the `spfquery` tool for the alternatives system: |
66 | # Rename the `spfquery` tool for the alternatives system: |
67 | mv debian/spfquery/usr/bin/spfquery debian/spfquery/usr/bin/spfquery.$(SOURCE_PACKAGE) |
67 | mv debian/spfquery/usr/bin/spfquery debian/spfquery/usr/bin/spfquery.$(SOURCE_PACKAGE) |
68 | mv debian/spfquery/usr/sbin/spfd debian/spfquery/usr/sbin/spfd.$(SOURCE_PACKAGE) |
68 | mv debian/spfquery/usr/sbin/spfd debian/spfquery/usr/sbin/spfd.$(SOURCE_PACKAGE) |
69 | dh_installdocs -a --link-doc=$(LIB_PACKAGE) |
69 | dh_installdocs -a --link-doc=$(LIB_PACKAGE) |
70 | dh_installchangelogs -a |
70 | dh_installchangelogs -a |
71 | dh_installman -a |
71 | dh_installman -a |
72 | dh_strip -a --dbg-package=$(LIB_PACKAGE)-dbg |
72 | dh_strip -a --dbg-package=$(LIB_PACKAGE)-dbg |
73 | dh_perl -a |
73 | dh_perl -a |
74 | dh_compress -a |
74 | dh_compress -a |
75 | dh_fixperms -a |
75 | dh_fixperms -a |
76 | dh_makeshlibs -V '$(LIB_PACKAGE) (>= 1.2.8~)' |
76 | dh_makeshlibs -V '$(LIB_PACKAGE) (>= 1.2.8~)' |
77 | dh_installdeb -a |
77 | dh_installdeb -a |
78 | dh_shlibdeps -a |
78 | dh_shlibdeps -a |
79 | dh_gencontrol -a |
79 | dh_gencontrol -a |
80 | dh_md5sums -a |
80 | dh_md5sums -a |
81 | dh_builddeb -a |
81 | dh_builddeb -a |
82 | 82 | ||
83 | binary: binary-arch |
83 | binary: binary-arch |
84 | 84 | ||
85 | get-orig-source: |
85 | get-orig-source: |
86 | wget http://www.libspf2.org/spf/libspf2-1.2.10.tar.gz |
86 | wget http://www.libspf2.org/spf/libspf2-1.2.10.tar.gz |
87 | 87 | ||
88 | .PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install get-orig-source |
88 | .PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install get-orig-source |