Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 2 Rev 29
1
#! /bin/sh /usr/share/dpatch/dpatch-run
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 20_spf_dns_include_std_headers.dpatch by Magnus Holmgren <magnus@kibibyte.se>
2
## 20_spf_dns_include_std_headers.dpatch by Magnus Holmgren <magnus@kibibyte.se>
3
##
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Include arpa/nameser.h and netdb.h from spf_dns.h instead of defining 
5
## DP: Include arpa/nameser.h and netdb.h from spf_dns.h instead of defining 
6
## DP: the constants needed unless certain HAVE_ macros are defined.
6
## DP: the constants needed unless certain HAVE_ macros are defined.
7
7
8
@DPATCH@
8
@DPATCH@
9
9
10
diff -Nur libspf2-1.2.5.dfsg/src/include/spf_dns.h libspf2-1.2.5.dfsg.new/src/include/spf_dns.h
10
diff -Nur libspf2-1.2.5.dfsg/src/include/spf_dns.h libspf2-1.2.5.dfsg.new/src/include/spf_dns.h
11
--- libspf2-1.2.5.dfsg/src/include/spf_dns.h	2004-08-29 16:59:33.000000000 +0200
11
--- libspf2-1.2.5.dfsg/src/include/spf_dns.h	2004-08-29 16:59:33.000000000 +0200
12
+++ libspf2-1.2.5.dfsg.new/src/include/spf_dns.h	2007-03-23 18:04:17.000000000 +0100
12
+++ libspf2-1.2.5.dfsg.new/src/include/spf_dns.h	2007-03-23 18:04:17.000000000 +0100
13
@@ -61,43 +61,12 @@
13
@@ -61,43 +61,12 @@
14
  * 
14
  * 
15
  */
15
  */
16
 
16
 
17
-
17
-
18
-/*
18
-/*
19
- * For those who don't have <arpa/nameserv.h>
19
- * For those who don't have <arpa/nameserv.h>
20
+/* The following two header files might not exist on all platforms,
20
+/* The following two header files might not exist on all platforms,
21
+ * but at least they exist on Debian with libc6.
21
+ * but at least they exist on Debian with libc6.
22
  */
22
  */
23
+#include <arpa/nameser.h>
23
+#include <arpa/nameser.h>
24
+#include <netdb.h>
24
+#include <netdb.h>
25
 
25
 
26
-#if !defined( HAVE_NS_TYPE )
26
-#if !defined( HAVE_NS_TYPE )
27
-
27
-
28
-#define	ns_t_invalid	0
28
-#define	ns_t_invalid	0
29
-#define	ns_t_a		1
29
-#define	ns_t_a		1
30
-#define	ns_t_ns		2
30
-#define	ns_t_ns		2
31
-#define	ns_t_cname	5
31
-#define	ns_t_cname	5
32
-#define	ns_t_ptr	12
32
-#define	ns_t_ptr	12
33
-#define	ns_t_mx		15
33
-#define	ns_t_mx		15
34
-#define	ns_t_txt	16
34
-#define	ns_t_txt	16
35
-#define ns_t_aaaa	28
35
-#define ns_t_aaaa	28
36
-/* #define ns_t_a6		38 */
36
-/* #define ns_t_a6		38 */
37
-#define	ns_t_any        255		/* Wildcard match. */
37
-#define	ns_t_any        255		/* Wildcard match. */
38
-
38
-
39
-typedef int	ns_type;
39
-typedef int	ns_type;
40
-#endif
40
-#endif
41
-
41
-
42
-#ifndef ns_t_invalid
42
-#ifndef ns_t_invalid
43
-#define	ns_t_invalid	0
43
-#define	ns_t_invalid	0
44
-#endif
44
-#endif
45
-
45
-
46
-
46
-
47
-/*
47
-/*
48
- * For those who don't have <netdb.h>
48
- * For those who don't have <netdb.h>
49
- */
49
- */
50
-
50
-
51
-#if !defined(HAVE_NETDB_H) && !defined(_WIN32)
51
-#if !defined(HAVE_NETDB_H) && !defined(_WIN32)
52
-#define NETDB_SUCCESS	0
52
-#define NETDB_SUCCESS	0
53
-#define	HOST_NOT_FOUND 	1		/* NXDOMAIN (authoritative answer)*/
53
-#define	HOST_NOT_FOUND 	1		/* NXDOMAIN (authoritative answer)*/
54
-#define	TRY_AGAIN	2		/* SERVFAIL (no authoritative answer)*/
54
-#define	TRY_AGAIN	2		/* SERVFAIL (no authoritative answer)*/
55
-#define	NO_RECOVERY	3		/* invalid/unimplmeneted query	*/
55
-#define	NO_RECOVERY	3		/* invalid/unimplmeneted query	*/
56
-#define	NO_DATA		4		/* host found, but no RR of req type*/
56
-#define	NO_DATA		4		/* host found, but no RR of req type*/
57
-#endif
57
-#endif
58
 typedef int SPF_dns_stat_t;
58
 typedef int SPF_dns_stat_t;
59
 
59
 
60
 typedef struct SPF_dns_server_struct SPF_dns_server_t;
60
 typedef struct SPF_dns_server_struct SPF_dns_server_t;