Rev 5 | Blame | Compare with Previous | Last modification | View Log | RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 21_spfquery_infininte_loop.dpatch by Magnus Holmgren <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Fix infinite loop in spfquery.c:unimplemented().
@DPATCH@
diff -urNad libspf2-1.2.5.dfsg~/src/spfquery/spfquery.c libspf2-1.2.5.dfsg/src/spfquery/spfquery.c
--- libspf2-1.2.5.dfsg~/src/spfquery/spfquery.c 2005-02-22 03:36:55.000000000 +0100
+++ libspf2-1.2.5.dfsg/src/spfquery/spfquery.c 2007-03-24 22:28:15.000000000 +0100
@@ -174,9 +174,7 @@
struct option *opt;
int i;
- i = 0;
- opt = &long_options[i];
- while (opt->name) {
+ for (i = 0; (opt = &long_options[i])->name; i++) {
if (flag == opt->val) {
fprintf(stderr, "Unimplemented option: -%s or -%c\n",
opt->name, flag);