Rev 14 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
14 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 23_spfquery_ipv6.dpatch by Matthias Cramer <matthias.cramer@interway.ch> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Make spfquery accept IPv6 addresses |
||
6 | |||
7 | @DPATCH@ |
||
8 | |||
9 | --- libspf2-1.2.5.orig/src/spfquery/spfquery.c 2005-02-22 03:36:55.000000000 +0100 |
||
10 | +++ libspf2-1.2.5.dfsg/src/spfquery/spfquery.c 2007-08-30 09:39:32.000000000 +0200 |
||
11 | @@ -604,7 +602,8 @@ |
||
12 | |||
13 | spf_request = SPF_request_new(spf_server); |
||
14 | |||
15 | - if (SPF_request_set_ipv4_str(spf_request, req->ip)) { |
||
16 | + if (SPF_request_set_ipv4_str(spf_request, req->ip) |
||
17 | + && SPF_request_set_ipv6_str(spf_request, req->ip)) { |
||
18 | printf( "Invalid IP address.\n" ); |
||
19 | CONTINUE_ERROR; |
||
20 |