Rev 14 | Blame | Compare with Previous | Last modification | View Log | RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 23_spfquery_ipv6.dpatch by Matthias Cramer <matthias.cramer@interway.ch>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make spfquery accept IPv6 addresses
@DPATCH@
--- libspf2-1.2.5.orig/src/spfquery/spfquery.c 2005-02-22 03:36:55.000000000 +0100
+++ libspf2-1.2.5.dfsg/src/spfquery/spfquery.c 2007-08-30 09:39:32.000000000 +0200
@@ -604,7 +602,8 @@
spf_request = SPF_request_new(spf_server);
- if (SPF_request_set_ipv4_str(spf_request, req->ip)) {
+ if (SPF_request_set_ipv4_str(spf_request, req->ip)
+ && SPF_request_set_ipv6_str(spf_request, req->ip)) {
printf( "Invalid IP address.\n" );
CONTINUE_ERROR;