Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
7 magnus 1
#!/bin/sh /usr/share/dpatch/dpatch-run
2
## 40_permanent_include_errors.dpatch by Robert Millan <rmh@aybabtu.com>, edited by Magnus Holmgren
3
##
4
## DP: Permanent error when processing an include: directive should in turn
5
## DP: produce permanent error (see the table in RFC 4408 / section 5.2).
6
 
7
@DPATCH@
8
 
9
diff -ur libspf2-1.2.5.dfsg.old/src/libspf2/spf_interpret.c libspf2-1.2.5.dfsg/src/libspf2/spf_interpret.c
10
--- libspf2-1.2.5.dfsg.old/src/libspf2/spf_interpret.c	2005-02-22 04:41:27.000000000 +0100
11
+++ libspf2-1.2.5.dfsg/src/libspf2/spf_interpret.c	2007-07-01 01:03:17.000000000 +0200
12
@@ -1022,7 +1042,10 @@
13
 				if (spf_record_subr)
14
 					SPF_record_free(spf_record_subr);
15
 				SPF_FREE_LOOKUP_DATA();
16
-				return DONE_TEMPERR( err );
17
+				if (err == SPF_E_DNS_ERROR)
18
+					return DONE_TEMPERR( err );
19
+				else
20
+					return DONE_PERMERR( err );
21
 			}
22
 
23
 			/*