Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 57 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#! /bin/sh /usr/share/dpatch/dpatch-run
## 01_private_glibc_functions.dpatch by Magnus Holmgren <holmgren@debian.org>
##
## DP: Avoid linking private glibc functions (specifically __ns_get16).

@DPATCH@
diff -urNad trunk~/configure.ac trunk/configure.ac
--- trunk~/configure.ac 2008-11-04 16:32:10.000000000 +0100
+++ trunk/configure.ac  2008-11-15 15:35:38.000000000 +0100
@@ -272,7 +272,8 @@
 AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
 
 AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag])
+AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
+AC_LIBOBJ(__ns_get16)
 
 AC_CONFIG_FILES([Makefile
                  Doxyfile
diff -urNad trunk~/configure trunk/configure
--- trunk~/configure    2008-11-04 16:32:56.000000000 +0100
+++ trunk/configure     2008-11-15 15:35:39.000000000 +0100
@@ -25752,8 +25752,7 @@
 
 
 
-
-for ac_func in __ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag
+for ac_func in __ns_initparse __ns_name_uncompress __ns_msg_getflag
 do
 as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
 { echo "$as_me:$LINENO: checking for $ac_func" >&5
@@ -25854,6 +25853,12 @@
 done
 
 
+case " $LIBOBJS " in
+  *" __ns_get16.$ac_objext "* ) ;;
+  *) LIBOBJS="$LIBOBJS __ns_get16.$ac_objext"
+ ;;
+esac
+
 
 ac_config_files="$ac_config_files Makefile Doxyfile src/Makefile src/include/Makefile src/libreplace/Makefile src/libspf2/Makefile src/spfquery/Makefile src/spftest/Makefile src/spfd/Makefile src/spf_example/Makefile"