Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 30 | Rev 57 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 30 Rev 37
Line 2... Line 2...
2
## 20_spf_dns_include_std_headers.dpatch by Magnus Holmgren <magnus@kibibyte.se>
2
## 20_spf_dns_include_std_headers.dpatch by Magnus Holmgren <magnus@kibibyte.se>
3
##
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Include arpa/nameser.h and netdb.h from spf_dns.h instead of defining 
5
## DP: Include arpa/nameser.h and netdb.h from spf_dns.h instead of defining 
6
## DP: the constants needed unless certain HAVE_ macros are defined.
6
## DP: the constants needed unless certain HAVE_ macros are defined.
-
 
7
## DP: Updated for libspf2 1.2.8/9 by Scott Kitterman <scott@kitterman.com>
7
8
8
@DPATCH@
9
@DPATCH@
9
-
 
10
diff -Nur libspf2-1.2.5.dfsg/src/include/spf_dns.h libspf2-1.2.5.dfsg.new/src/include/spf_dns.h
10
diff -urNad libspf2-1.2.9~/src/include/spf_dns.h libspf2-1.2.9/src/include/spf_dns.h
11
--- libspf2-1.2.5.dfsg/src/include/spf_dns.h	2004-08-29 16:59:33.000000000 +0200
11
--- libspf2-1.2.9~/src/include/spf_dns.h	2008-10-27 12:27:14.000000000 -0400
12
+++ libspf2-1.2.5.dfsg.new/src/include/spf_dns.h	2007-03-23 18:04:17.000000000 +0100
12
+++ libspf2-1.2.9/src/include/spf_dns.h	2008-11-04 10:10:58.000000000 -0500
13
@@ -61,48 +61,16 @@
13
@@ -63,48 +63,19 @@
14
  * 
14
  * 
15
  */
15
  */
16
 
16
 
17
-
-
 
18
-/*
-
 
19
- * For those who don't have <arpa/nameserv.h>
-
 
20
+/* The following two header files might not exist on all platforms,
17
+/* The following two header files might not exist on all platforms,
21
+ * but at least they exist on Debian with libc6.
18
+ * but at least they exist on Debian with libc6.
22
  */
19
+ */
23
+#include <arpa/nameser.h>
20
+#include <arpa/nameser.h>
24
+#include <netdb.h>
21
+#include <netdb.h>
25
 
22
 
-
 
23
 /*
-
 
24
- * For those who don't have <arpa/nameserv.h>
-
 
25
+ * Type 99 decl does not exist in Debian libc6 (not even 2.7)
-
 
26
  */
-
 
27
-
26
-/* XXX This should use a more sensible define. */
28
-/* XXX This should use a more sensible define. */
27
-#if !defined( HAVE_NS_TYPE )
29
-#if !defined( HAVE_NS_TYPE )
28
-
30
-
29
-#define	ns_t_invalid	0
31
-#define	ns_t_invalid	0
30
-#define	ns_t_a		1
32
-#define	ns_t_a		1
Line 33... Line 35...
33
-#define	ns_t_ptr	12
35
-#define	ns_t_ptr	12
34
-#define	ns_t_mx		15
36
-#define	ns_t_mx		15
35
-#define	ns_t_txt	16
37
-#define	ns_t_txt	16
36
-#define ns_t_aaaa	28
38
-#define ns_t_aaaa	28
37
-/* #define ns_t_a6		38 */
39
-/* #define ns_t_a6		38 */
38
-#define	ns_t_any        255		/* Wildcard match. */
40
-#define	ns_t_any        255		/**< Wildcard match. */
39
-
41
-
40
-typedef int	ns_type;
42
-typedef int	ns_type;
41
-#endif
43
-#endif
42
-
44
-
43
 #if ! HAVE_DECL_NS_T_SPF
45
 #if ! HAVE_DECL_NS_T_SPF
Line 53... Line 55...
53
- * For those who don't have <netdb.h>
55
- * For those who don't have <netdb.h>
54
- */
56
- */
55
-
57
-
56
-#if !defined(HAVE_NETDB_H) && !defined(_WIN32)
58
-#if !defined(HAVE_NETDB_H) && !defined(_WIN32)
57
-#define NETDB_SUCCESS	0
59
-#define NETDB_SUCCESS	0
58
-#define	HOST_NOT_FOUND 	1		/* NXDOMAIN (authoritative answer)*/
60
-#define	HOST_NOT_FOUND 	1		/**< NXDOMAIN (authoritative answer)*/
59
-#define	TRY_AGAIN	2		/* SERVFAIL (no authoritative answer)*/
61
-#define	TRY_AGAIN		2		/**< SERVFAIL (no authoritative answer)*/
60
-#define	NO_RECOVERY	3		/* invalid/unimplmeneted query	*/
62
-#define	NO_RECOVERY		3		/**< invalid/unimplmeneted query	*/
61
-#define	NO_DATA		4		/* host found, but no RR of req type*/
63
-#define	NO_DATA			4		/**< host found, but no RR of req type*/
62
-#endif
64
-#endif
63
 typedef int SPF_dns_stat_t;
65
 typedef int SPF_dns_stat_t;
64
 
66
 
65
 typedef struct SPF_dns_server_struct SPF_dns_server_t;
67
 typedef struct SPF_dns_server_struct SPF_dns_server_t;