Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 43 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
43 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 01_private_glibc_functions.dpatch by Magnus Holmgren <holmgren@debian.org>
3
##
4
## DP: Avoid linking private glibc functions (specifically __ns_get16).
5
 
6
@DPATCH@
7
diff -urNad trunk~/configure.ac trunk/configure.ac
8
--- trunk~/configure.ac	2008-11-04 16:32:10.000000000 +0100
9
+++ trunk/configure.ac	2008-11-15 15:35:38.000000000 +0100
10
@@ -272,7 +272,8 @@
11
 AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
12
 
13
 AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
14
-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag])
15
+AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
16
+AC_LIBOBJ(__ns_get16)
17
 
18
 AC_CONFIG_FILES([Makefile
19
                  Doxyfile
20
diff -urNad trunk~/configure trunk/configure
21
--- trunk~/configure	2008-11-04 16:32:56.000000000 +0100
22
+++ trunk/configure	2008-11-15 15:35:39.000000000 +0100
23
@@ -25752,8 +25752,7 @@
24
 
25
 
26
 
27
-
28
-for ac_func in __ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag
29
+for ac_func in __ns_initparse __ns_name_uncompress __ns_msg_getflag
30
 do
31
 as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
32
 { echo "$as_me:$LINENO: checking for $ac_func" >&5
33
@@ -25854,6 +25853,12 @@
34
 done
35
 
36
 
37
+case " $LIBOBJS " in
38
+  *" __ns_get16.$ac_objext "* ) ;;
39
+  *) LIBOBJS="$LIBOBJS __ns_get16.$ac_objext"
40
+ ;;
41
+esac
42
+
43
 
44
 ac_config_files="$ac_config_files Makefile Doxyfile src/Makefile src/include/Makefile src/libreplace/Makefile src/libspf2/Makefile src/spfquery/Makefile src/spftest/Makefile src/spfd/Makefile src/spf_example/Makefile"
45