Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Go to most recent revision | Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
53 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## ipv6_buffer_miscalculation.dpatch by Matthias Scheler <tron@netbsd.org>
3
##
4
## DP: Fix an abort() caused by miscalculating the size of an internal buffer.
5
## DP: This can crash applications using "libspf2" (e.g. "milter-greylist")
6
## DP: in an e-mail gets delivered via SMTP over IPv6 depending on the
7
## DP: remote machine's IPv6 address.
8
 
9
@DPATCH@
10
--- a/src/libspf2/spf_expand.c  2008-11-03 21:29:00.000000000 +0000
11
+++ b/src/libspf2/spf_expand.c  2009-09-08 11:27:52.000000000 +0100
12
@@ -245,7 +245,7 @@
13
                case PARM_CLIENT_IP:            /* SMTP client IP                               */
14
 #ifdef COMPUTE
15
                        if (compute_length) {
16
-                               len = sizeof(ip6_buf);
17
+                               len = sizeof(ip6_rbuf);
18
                                if (d->dv.url_encode)
19
                                        len *= 3;
20
                                buflen += len;