Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
58 magnus 1
Author: Magnus Holmgren <holmgren@debian.org>
2
Description: Avoid linking private glibc functions (specifically __ns_get16).
43 magnus 3
 
4
--- trunk~/configure.ac 2008-11-04 16:32:10.000000000 +0100
5
+++ trunk/configure.ac  2008-11-15 15:35:38.000000000 +0100
6
@@ -272,7 +272,8 @@
7
 AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
8
 
9
 AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
10
-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag])
11
+AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
12
+AC_LIBOBJ(__ns_get16)
13
 
14
 AC_CONFIG_FILES([Makefile
15
                  Doxyfile
16
diff -urNad trunk~/configure trunk/configure
17
--- trunk~/configure    2008-11-04 16:32:56.000000000 +0100
18
+++ trunk/configure     2008-11-15 15:35:39.000000000 +0100
19
@@ -25752,8 +25752,7 @@
20
 
21
 
22
 
23
-
24
-for ac_func in __ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag
25
+for ac_func in __ns_initparse __ns_name_uncompress __ns_msg_getflag
26
 do
27
 as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
28
 { echo "$as_me:$LINENO: checking for $ac_func" >&5
29
@@ -25854,6 +25853,12 @@
30
 done
31
 
32
 
33
+case " $LIBOBJS " in
34
+  *" __ns_get16.$ac_objext "* ) ;;
35
+  *) LIBOBJS="$LIBOBJS __ns_get16.$ac_objext"
36
+ ;;
37
+esac
38
+
39
 
40
 ac_config_files="$ac_config_files Makefile Doxyfile src/Makefile src/include/Makefile src/libreplace/Makefile src/libspf2/Makefile src/spfquery/Makefile src/spftest/Makefile src/spfd/Makefile src/spf_example/Makefile"
41