Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 2 Rev 5
Line 11... Line 11...
11
                 src/include/spf_win32.h"
11
                 src/include/spf_win32.h"
12
12
13
set -e
13
set -e
14
14
15
dpatch_patch() {
15
dpatch_patch() {
-
 
16
    if [ ! -f debian/patched/patched-line-endings.tar.gz ]; then
-
 
17
        tar -czf debian/patched/patched-line-endings.tar.gz $FILES_WITH_CRLF
16
    # Change line endings to LF in files with CRLF
18
        # Change line endings to LF in files with CRLF
17
    sed -ri -e 's/\r$//' $FILES_WITH_CRLF
19
        sed -ri -e 's/\r$//' $FILES_WITH_CRLF
-
 
20
    fi
18
}
21
}
19
22
20
dpatch_unpatch() {
23
dpatch_unpatch() {
21
    # Change line endings back to CRLF in files that had it in the tarball
24
    # Change line endings back to CRLF in files that had it in the tarball
22
    # Unfortunately there are exceptions ... have to watch out for changes
-
 
23
    # in future upstream versions (or simply make backups instead).
-
 
24
    sed -ri -e '/\r$|^#pragma comment/!s/$/\r/' $FILES_WITH_CRLF
-
 
25
    sed -ri -e '$s/\r$//' src/libspf2/spf_dns_windns.c
25
    tar -xzf debian/patched/patched-line-endings.tar.gz
26
}
26
}
27
27
28
DPATCH_LIB_NO_DEFAULT=1
28
DPATCH_LIB_NO_DEFAULT=1
29
29
30
. /usr/share/dpatch/dpatch.lib.sh
30
. /usr/share/dpatch/dpatch.lib.sh