Rev 30 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 20_spf_dns_include_std_headers.dpatch by Magnus Holmgren <magnus@kibibyte.se> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Include arpa/nameser.h and netdb.h from spf_dns.h instead of defining |
||
6 | ## DP: the constants needed unless certain HAVE_ macros are defined. |
||
37 | magnus | 7 | ## DP: Updated for libspf2 1.2.8/9 by Scott Kitterman <scott@kitterman.com> |
2 | magnus | 8 | |
9 | @DPATCH@ |
||
37 | magnus | 10 | diff -urNad libspf2-1.2.9~/src/include/spf_dns.h libspf2-1.2.9/src/include/spf_dns.h |
11 | --- libspf2-1.2.9~/src/include/spf_dns.h 2008-10-27 12:27:14.000000000 -0400 |
||
12 | +++ libspf2-1.2.9/src/include/spf_dns.h 2008-11-04 10:10:58.000000000 -0500 |
||
13 | @@ -63,48 +63,19 @@ |
||
2 | magnus | 14 | * |
15 | */ |
||
16 | |||
17 | +/* The following two header files might not exist on all platforms, |
||
18 | + * but at least they exist on Debian with libc6. |
||
37 | magnus | 19 | + */ |
2 | magnus | 20 | +#include <arpa/nameser.h> |
21 | +#include <netdb.h> |
||
22 | |||
37 | magnus | 23 | /* |
24 | - * For those who don't have <arpa/nameserv.h> |
||
25 | + * Type 99 decl does not exist in Debian libc6 (not even 2.7) |
||
26 | */ |
||
27 | - |
||
30 | magnus | 28 | -/* XXX This should use a more sensible define. */ |
2 | magnus | 29 | -#if !defined( HAVE_NS_TYPE ) |
30 | - |
||
31 | -#define ns_t_invalid 0 |
||
32 | -#define ns_t_a 1 |
||
33 | -#define ns_t_ns 2 |
||
34 | -#define ns_t_cname 5 |
||
35 | -#define ns_t_ptr 12 |
||
36 | -#define ns_t_mx 15 |
||
37 | -#define ns_t_txt 16 |
||
38 | -#define ns_t_aaaa 28 |
||
39 | -/* #define ns_t_a6 38 */ |
||
37 | magnus | 40 | -#define ns_t_any 255 /**< Wildcard match. */ |
2 | magnus | 41 | - |
42 | -typedef int ns_type; |
||
43 | -#endif |
||
44 | - |
||
30 | magnus | 45 | #if ! HAVE_DECL_NS_T_SPF |
46 | #define ns_t_spf 99 |
||
47 | #endif |
||
48 | |||
49 | -#if ! HAVE_DECL_NS_T_INVALID |
||
2 | magnus | 50 | -#define ns_t_invalid 0 |
51 | -#endif |
||
52 | - |
||
53 | - |
||
54 | -/* |
||
55 | - * For those who don't have <netdb.h> |
||
56 | - */ |
||
57 | - |
||
58 | -#if !defined(HAVE_NETDB_H) && !defined(_WIN32) |
||
59 | -#define NETDB_SUCCESS 0 |
||
37 | magnus | 60 | -#define HOST_NOT_FOUND 1 /**< NXDOMAIN (authoritative answer)*/ |
61 | -#define TRY_AGAIN 2 /**< SERVFAIL (no authoritative answer)*/ |
||
62 | -#define NO_RECOVERY 3 /**< invalid/unimplmeneted query */ |
||
63 | -#define NO_DATA 4 /**< host found, but no RR of req type*/ |
||
2 | magnus | 64 | -#endif |
65 | typedef int SPF_dns_stat_t; |
||
66 | |||
67 | typedef struct SPF_dns_server_struct SPF_dns_server_t; |