Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 2 Rev 30
Line 8... Line 8...
8
@DPATCH@
8
@DPATCH@
9
9
10
diff -Nur libspf2-1.2.5.dfsg/src/include/spf_dns.h libspf2-1.2.5.dfsg.new/src/include/spf_dns.h
10
diff -Nur libspf2-1.2.5.dfsg/src/include/spf_dns.h libspf2-1.2.5.dfsg.new/src/include/spf_dns.h
11
--- libspf2-1.2.5.dfsg/src/include/spf_dns.h	2004-08-29 16:59:33.000000000 +0200
11
--- libspf2-1.2.5.dfsg/src/include/spf_dns.h	2004-08-29 16:59:33.000000000 +0200
12
+++ libspf2-1.2.5.dfsg.new/src/include/spf_dns.h	2007-03-23 18:04:17.000000000 +0100
12
+++ libspf2-1.2.5.dfsg.new/src/include/spf_dns.h	2007-03-23 18:04:17.000000000 +0100
13
@@ -61,43 +61,12 @@
13
@@ -61,48 +61,16 @@
14
  * 
14
  * 
15
  */
15
  */
16
 
16
 
17
-
17
-
18
-/*
18
-/*
Line 21... Line 21...
21
+ * but at least they exist on Debian with libc6.
21
+ * but at least they exist on Debian with libc6.
22
  */
22
  */
23
+#include <arpa/nameser.h>
23
+#include <arpa/nameser.h>
24
+#include <netdb.h>
24
+#include <netdb.h>
25
 
25
 
-
 
26
-/* XXX This should use a more sensible define. */
26
-#if !defined( HAVE_NS_TYPE )
27
-#if !defined( HAVE_NS_TYPE )
27
-
28
-
28
-#define	ns_t_invalid	0
29
-#define	ns_t_invalid	0
29
-#define	ns_t_a		1
30
-#define	ns_t_a		1
30
-#define	ns_t_ns		2
31
-#define	ns_t_ns		2
Line 37... Line 38...
37
-#define	ns_t_any        255		/* Wildcard match. */
38
-#define	ns_t_any        255		/* Wildcard match. */
38
-
39
-
39
-typedef int	ns_type;
40
-typedef int	ns_type;
40
-#endif
41
-#endif
41
-
42
-
-
 
43
 #if ! HAVE_DECL_NS_T_SPF
42
-#ifndef ns_t_invalid
44
 #define ns_t_spf	99
-
 
45
 #endif
-
 
46
 
-
 
47
-#if ! HAVE_DECL_NS_T_INVALID
43
-#define	ns_t_invalid	0
48
-#define	ns_t_invalid	0
44
-#endif
49
-#endif
45
-
50
-
46
-
51
-
47
-/*
52
-/*