Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
91 | magnus | 1 | --- a/src/include/spf_log.h |
2 | +++ b/src/include/spf_log.h |
||
3 | @@ -63,10 +63,10 @@ void SPF_debugv( const char *file, int l |
||
4 | |||
5 | #if defined( __STDC_VERSION__ ) && __STDC_VERSION__ >= 199901L |
||
6 | |||
7 | -#define SPF_errorf(format, ... ) SPF_errorx( __FILE__, __LINE__, format, __VA_ARGS__ ) |
||
8 | -#define SPF_warningf(format, ... ) SPF_warningx( __FILE__, __LINE__, format, __VA_ARGS__ ) |
||
9 | -#define SPF_infof(format, ... ) SPF_infox( __FILE__, __LINE__, format, __VA_ARGS__ ) |
||
10 | -#define SPF_debugf(format, ... ) SPF_debugx( __FILE__, __LINE__, format, __VA_ARGS__ ) |
||
11 | +#define SPF_errorf(format, ... ) SPF_errorx( __FILE__, __LINE__, format, ##__VA_ARGS__ ) |
||
12 | +#define SPF_warningf(format, ... ) SPF_warningx( __FILE__, __LINE__, format, ##__VA_ARGS__ ) |
||
13 | +#define SPF_infof(format, ... ) SPF_infox( __FILE__, __LINE__, format, ##__VA_ARGS__ ) |
||
14 | +#define SPF_debugf(format, ... ) SPF_debugx( __FILE__, __LINE__, format, ##__VA_ARGS__ ) |
||
15 | |||
16 | #elif defined( __GNUC__ ) |
||
17 |