Rev 53 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
58 | magnus | 1 | Author: Matthias Scheler <tron@netbsd.org> |
2 | Description: Fix an abort() caused by miscalculating the size of an internal buffer. |
||
3 | This can crash applications using "libspf2" (e.g. "milter-greylist") |
||
4 | in an e-mail gets delivered via SMTP over IPv6 depending on the |
||
5 | remote machine's IPv6 address. |
||
53 | magnus | 6 | |
7 | --- a/src/libspf2/spf_expand.c 2008-11-03 21:29:00.000000000 +0000 |
||
8 | +++ b/src/libspf2/spf_expand.c 2009-09-08 11:27:52.000000000 +0100 |
||
9 | @@ -245,7 +245,7 @@ |
||
10 | case PARM_CLIENT_IP: /* SMTP client IP */ |
||
11 | #ifdef COMPUTE |
||
12 | if (compute_length) { |
||
13 | - len = sizeof(ip6_buf); |
||
14 | + len = sizeof(ip6_rbuf); |
||
15 | if (d->dv.url_encode) |
||
16 | len *= 3; |
||
17 | buflen += len; |