Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 68 | Rev 71 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
 
3
SOURCE_PACKAGE = libspf2
61 magnus 4
LIB_PACKAGE = libspf2-2
2 magnus 5
 
61 magnus 6
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
2 magnus 8
 
61 magnus 9
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
10
  buildflags := --build=$(DEB_BUILD_GNU_TYPE)
11
else
12
  buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
13
endif
2 magnus 14
 
61 magnus 15
DEB_LDFLAGS_MAINT_APPEND = -Wl,--version-script=$(CURDIR)/debian/libspf2.ver
16
buildflags += $(shell DEB_LDFLAGS_MAINT_APPEND="$(DEB_LDFLAGS_MAINT_APPEND)" \
17
 dpkg-buildflags --export=configure)
18
 
19
config.status: configure
20
	dh_testdir
21
	# Add here commands to configure the package.
22
	dh_autotools-dev_updateconfig
68 magnus 23
	./configure --enable-perl --prefix=/usr $(buildflags)
61 magnus 24
 
25
build: build-arch
26
build-indep:
27
build-arch: build-arch-stamp
28
build-arch-stamp: config.status
29
	dh_testdir
30
 
31
	$(MAKE)
32
 
33
	touch "$@"
34
 
35
clean:
36
	dh_testdir
37
	dh_testroot
38
	rm -f build-arch-stamp
39
 
40
	[ ! -f Makefile ] || $(MAKE) distclean
41
 
42
	dh_autotools-dev_restoreconfig
43
	dh_clean
44
 
45
install: build-arch
46
	dh_testdir
47
	dh_testroot
48
	dh_prep
49
 
68 magnus 50
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp INSTALLDIRS=vendor
61 magnus 51
 
52
binary-arch: install
53
	dh_testdir
54
	dh_testroot
55
	dh_install -a
2 magnus 56
#	Rename the `spfquery` tool for the alternatives system:
57
	mv debian/spfquery/usr/bin/spfquery debian/spfquery/usr/bin/spfquery.$(SOURCE_PACKAGE)
58
	mv debian/spfquery/usr/sbin/spfd debian/spfquery/usr/sbin/spfd.$(SOURCE_PACKAGE)
61 magnus 59
	dh_installdocs -a --link-doc=$(LIB_PACKAGE)
60
	dh_installchangelogs -a
61
	dh_installman -a
62
	dh_strip -a --dbg-package=$(LIB_PACKAGE)-dbg
68 magnus 63
	dh_perl -a
61 magnus 64
	dh_compress -a
65
	dh_fixperms -a
69 magnus 66
	dh_makeshlibs -V '$(LIB_PACKAGE) (>= 1.2.10)'
61 magnus 67
	dh_installdeb -a
68
	dh_shlibdeps -a
69
	dh_gencontrol -a
70
	dh_md5sums -a
71
	dh_builddeb -a
2 magnus 72
 
61 magnus 73
binary: binary-arch
74
 
2 magnus 75
get-orig-source:
41 magnus 76
	wget http://www.libspf2.org/spf/libspf2-1.2.9.tar.gz
61 magnus 77
 
78
.PHONY: build build-indep build-arch clean clean-patched binary-indep binary-arch binary install get-orig-source