Rev 69 | Rev 72 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 69 | Rev 71 | ||
---|---|---|---|
Line 10... | Line 10... | ||
10 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
10 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) |
11 | else |
11 | else |
12 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
12 | buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
13 | endif |
13 | endif |
14 | 14 | ||
- | 15 | CFLAGS := $(shell dpkg-buildflags --get CFLAGS) |
|
- | 16 | CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS) |
|
- | 17 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
|
- | 18 | perlld := $(shell perl -MConfig -e 'print $$Config{ld}') |
|
- | 19 | ||
15 | DEB_LDFLAGS_MAINT_APPEND = -Wl,--version-script=$(CURDIR)/debian/libspf2.ver |
20 | DEB_LDFLAGS_MAINT_APPEND = -Wl,--version-script=$(CURDIR)/debian/libspf2.ver |
16 | buildflags += $(shell DEB_LDFLAGS_MAINT_APPEND="$(DEB_LDFLAGS_MAINT_APPEND)" \ |
21 | buildflags += $(shell DEB_LDFLAGS_MAINT_APPEND="$(DEB_LDFLAGS_MAINT_APPEND)" \ |
17 | dpkg-buildflags --export=configure) |
22 | dpkg-buildflags --export=configure) |
18 | 23 | ||
19 | config.status: configure |
24 | config.status: configure |
20 | dh_testdir |
25 | dh_testdir |
21 | # Add here commands to configure the package. |
26 | # Add here commands to configure the package. |
22 | dh_autotools-dev_updateconfig |
27 | dh_autotools-dev_updateconfig |
23 | ./configure --enable-perl --prefix=/usr $(buildflags) |
28 | ./configure --prefix=/usr $(buildflags) |
24 | 29 | ||
25 | build: build-arch |
30 | build: build-arch |
26 | build-indep: |
31 | build-indep: |
27 | build-arch: build-arch-stamp |
32 | build-arch: build-arch-stamp |
28 | build-arch-stamp: config.status |
33 | build-arch-stamp: config.status |
29 | dh_testdir |
34 | dh_testdir |
30 | 35 | ||
31 | $(MAKE) |
36 | $(MAKE) |
- | 37 | cd perl && perl Makefile.PL INSTALLDIRS=vendor \ |
|
- | 38 | OPTIMIZE="$(CPPFLAGS) $(CFLAGS)" LD="$(perlld) $(CFLAGS) $(LDFLAGS)" |
|
- | 39 | $(MAKE) -C perl LD_RUN_PATH= |
|
32 | 40 | ||
33 | touch "$@" |
41 | touch "$@" |
34 | 42 | ||
35 | clean: |
43 | clean: |
36 | dh_testdir |
44 | dh_testdir |
37 | dh_testroot |
45 | dh_testroot |
38 | rm -f build-arch-stamp |
46 | rm -f build-arch-stamp |
39 | 47 | ||
40 | [ ! -f Makefile ] || $(MAKE) distclean |
48 | [ ! -f Makefile ] || $(MAKE) distclean |
- | 49 | [ ! -f perl/Makefile ] || $(MAKE) -C perl realclean |
|
41 | 50 | ||
42 | dh_autotools-dev_restoreconfig |
51 | dh_autotools-dev_restoreconfig |
43 | dh_clean |
52 | dh_clean |
44 | 53 | ||
45 | install: build-arch |
54 | install: build-arch |
46 | dh_testdir |
55 | dh_testdir |
47 | dh_testroot |
56 | dh_testroot |
48 | dh_prep |
57 | dh_prep |
49 | 58 | ||
50 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp INSTALLDIRS=vendor |
59 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
- | 60 | $(MAKE) -C perl install DESTDIR=$(CURDIR)/debian/tmp |
|
51 | 61 | ||
52 | binary-arch: install |
62 | binary-arch: install |
53 | dh_testdir |
63 | dh_testdir |
54 | dh_testroot |
64 | dh_testroot |
55 | dh_install -a |
65 | dh_install -a |