Rev 3 | Rev 5 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 4 | ||
---|---|---|---|
Line 1... | Line 1... | ||
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | 2 | ||
3 | export LIBTOOLIZE = libtoolize --install |
3 | export DH_VERBOSE=1 |
4 | 4 | ||
5 | configure: configure-stamp |
- | |
6 | configure-stamp: |
5 | configure: |
7 | dh_testdir |
6 | dh_testdir |
8 | [ -f debian/autoreconf.before ] || dh_autoreconf |
7 | cp /usr/share/misc/config.* autoconf |
- | 8 | autoreconf -f -v -i |
|
9 | ./configure \ |
9 | ./configure \ |
10 | --prefix=/usr \ |
10 | --prefix=/usr \ |
11 | --mandir=\$${prefix}/share/man |
11 | --mandir=\$${prefix}/share/man |
12 | touch configure-stamp |
12 | touch configure-stamp |
13 | 13 | ||
- | 14 | configure-stamp: configure |
|
- | 15 | ||
14 | build: build-stamp |
16 | build-stamp: build |
- | 17 | ||
15 | build-stamp: configure-stamp |
18 | build: configure-stamp |
16 | dh_testdir |
19 | dh_testdir |
17 | $(MAKE) |
20 | $(MAKE) |
18 | touch build-stamp |
21 | touch build-stamp |
19 | 22 | ||
20 | clean: |
23 | clean: |
21 | dh_testdir |
24 | dh_testdir |
22 | dh_testroot |
25 | dh_testroot |
23 | # Stale build files |
26 | # Stale build files |
- | 27 | [ ! -f Makefile ] || $(MAKE) clean |
|
24 | [ ! -f Makefile ] || $(MAKE) distclean |
28 | [ ! -f Makefile ] || $(MAKE) distclean |
25 | -rm -f build-stamp configure-stamp |
29 | -rm -f build-stamp configure-stamp |
- | 30 | -rm -rf config.log autoconf/config.guess autoconf/config.sub autoconf/depcomp autoconf/ltmain.sh autoconf/missing autoconf/mkinstalldirs autom4te.cache libtool |
|
26 | dh_autoreconf_clean |
31 | dh_clean |
27 | dh_clean libtool configure |
- | |
28 | 32 | ||
29 | install: build-stamp |
33 | install: build-stamp |
30 | dh_testdir |
34 | dh_testdir |
31 | dh_testroot |
35 | dh_testroot |
32 | dh_prep |
36 | dh_installdirs |
33 | 37 | ||
34 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
38 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
35 | 39 | ||
36 | binary-indep: build install |
40 | binary-indep: build install |
37 | 41 | ||
Line 39... | Line 43... | ||
39 | dh_testdir |
43 | dh_testdir |
40 | dh_testroot |
44 | dh_testroot |
41 | dh_install --sourcedir=debian/tmp |
45 | dh_install --sourcedir=debian/tmp |
42 | 46 | ||
43 | dh_installdocs |
47 | dh_installdocs |
44 | dh_installexamples |
48 | dh_installexamples -p libtar-dev libtar/libtar.c libtar/Makefile |
45 | dh_installman |
49 | dh_installman |
46 | dh_installchangelogs ChangeLog |
50 | dh_installchangelogs ChangeLog |
47 | dh_link |
51 | dh_link |
48 | dh_strip |
52 | dh_strip |
49 | dh_compress |
53 | dh_compress |