Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 9 | Rev 40 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
 
5 magnus 3
export LIBTOOLIZE = libtoolize --install
3 magnus 4
 
5 magnus 5
configure: configure-stamp
6
configure-stamp:
3 magnus 7
	dh_testdir
5 magnus 8
	[ -f debian/autoreconf.before ] || dh_autoreconf
3 magnus 9
	./configure \
10
		--prefix=/usr \
12 magnus 11
		--mandir=\$${prefix}/share/man \
12
		$(shell dpkg-buildflags --export=configure)
3 magnus 13
	touch configure-stamp
14
 
9 magnus 15
build-arch: build
16
build-indep:
5 magnus 17
build: build-stamp
18
build-stamp: configure-stamp
3 magnus 19
	dh_testdir
20
	$(MAKE)
21
	touch build-stamp
22
 
23
clean:
24
	dh_testdir
25
	dh_testroot
26
	# Stale build files
27
	[ ! -f Makefile ] || $(MAKE) distclean
28
	-rm -f build-stamp configure-stamp
5 magnus 29
	dh_autoreconf_clean
30
	dh_clean libtool configure
3 magnus 31
 
32
install: build-stamp
33
	dh_testdir
34
	dh_testroot
5 magnus 35
	dh_prep
3 magnus 36
 
37
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
38
 
7 magnus 39
binary-indep:
3 magnus 40
 
41
binary-arch: install
42
	dh_testdir
43
	dh_testroot
44
	dh_install --sourcedir=debian/tmp
45
 
46
	dh_installdocs
5 magnus 47
	dh_installexamples
3 magnus 48
	dh_installman
49
	dh_installchangelogs ChangeLog
50
	dh_link
51
	dh_strip
52
	dh_compress
53
	dh_fixperms
54
	dh_makeshlibs
55
	dh_installdeb
56
	dh_shlibdeps
57
	dh_gencontrol
58
	dh_md5sums
59
	dh_builddeb
60
 
61
binary: binary-indep binary-arch
62
.PHONY: build clean binary-indep binary-arch binary install configure