Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 5 | Rev 9 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
 
5 magnus 3
export LIBTOOLIZE = libtoolize --install
3 magnus 4
 
5 magnus 5
configure: configure-stamp
6
configure-stamp:
3 magnus 7
	dh_testdir
5 magnus 8
	[ -f debian/autoreconf.before ] || dh_autoreconf
3 magnus 9
	./configure \
10
		--prefix=/usr \
11
		--mandir=\$${prefix}/share/man
12
	touch configure-stamp
13
 
5 magnus 14
build: build-stamp
15
build-stamp: configure-stamp
3 magnus 16
	dh_testdir
17
	$(MAKE)
18
	touch build-stamp
19
 
20
clean:
21
	dh_testdir
22
	dh_testroot
23
	# Stale build files
24
	[ ! -f Makefile ] || $(MAKE) distclean
25
	-rm -f build-stamp configure-stamp
5 magnus 26
	dh_autoreconf_clean
27
	dh_clean libtool configure
3 magnus 28
 
29
install: build-stamp
30
	dh_testdir
31
	dh_testroot
5 magnus 32
	dh_prep
3 magnus 33
 
34
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
35
 
7 magnus 36
binary-indep:
3 magnus 37
 
38
binary-arch: install
39
	dh_testdir
40
	dh_testroot
41
	dh_install --sourcedir=debian/tmp
42
 
43
	dh_installdocs
5 magnus 44
	dh_installexamples
3 magnus 45
	dh_installman
46
	dh_installchangelogs ChangeLog
47
	dh_link
48
	dh_strip
49
	dh_compress
50
	dh_fixperms
51
	dh_makeshlibs
52
	dh_installdeb
53
	dh_shlibdeps
54
	dh_gencontrol
55
	dh_md5sums
56
	dh_builddeb
57
 
58
binary: binary-indep binary-arch
59
.PHONY: build clean binary-indep binary-arch binary install configure