Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 7 | Rev 12 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
 
5 magnus 3
export LIBTOOLIZE = libtoolize --install
3 magnus 4
 
5 magnus 5
configure: configure-stamp
6
configure-stamp:
3 magnus 7
	dh_testdir
5 magnus 8
	[ -f debian/autoreconf.before ] || dh_autoreconf
3 magnus 9
	./configure \
10
		--prefix=/usr \
11
		--mandir=\$${prefix}/share/man
12
	touch configure-stamp
13
 
9 magnus 14
build-arch: build
15
build-indep:
5 magnus 16
build: build-stamp
17
build-stamp: configure-stamp
3 magnus 18
	dh_testdir
19
	$(MAKE)
20
	touch build-stamp
21
 
22
clean:
23
	dh_testdir
24
	dh_testroot
25
	# Stale build files
26
	[ ! -f Makefile ] || $(MAKE) distclean
27
	-rm -f build-stamp configure-stamp
5 magnus 28
	dh_autoreconf_clean
29
	dh_clean libtool configure
3 magnus 30
 
31
install: build-stamp
32
	dh_testdir
33
	dh_testroot
5 magnus 34
	dh_prep
3 magnus 35
 
36
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
37
 
7 magnus 38
binary-indep:
3 magnus 39
 
40
binary-arch: install
41
	dh_testdir
42
	dh_testroot
43
	dh_install --sourcedir=debian/tmp
44
 
45
	dh_installdocs
5 magnus 46
	dh_installexamples
3 magnus 47
	dh_installman
48
	dh_installchangelogs ChangeLog
49
	dh_link
50
	dh_strip
51
	dh_compress
52
	dh_fixperms
53
	dh_makeshlibs
54
	dh_installdeb
55
	dh_shlibdeps
56
	dh_gencontrol
57
	dh_md5sums
58
	dh_builddeb
59
 
60
binary: binary-indep binary-arch
61
.PHONY: build clean binary-indep binary-arch binary install configure