Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
5 magnus 1
Author: James Morrison <phython@debian.org>
2
Description: Document stupidity of tartype_t in libtar.c.
3
Bug-Debian: http://bugs.debian.org/309945
4
 
5
--- a/libtar/libtar.c
6
+++ b/libtar/libtar.c
7
@@ -19,6 +19,7 @@
8
 #include <sys/param.h>
9
 
10
 #ifdef STDC_HEADERS
11
+# include <stdlib.h>
12
 # include <string.h>
13
 #endif
14
 
15
@@ -91,6 +92,10 @@ gzopen_frontend(char *pathname, int ofla
16
                return -1;
17
        }
18
 
19
+       /* This is a bad thing to do on big-endian lp64 systems, where the
20
+          size and placement of integers is different than pointers.
21
+          However, to fix the problem 4 wrapper functions would be needed and
22
+          an extra bit of data associating GZF with the wrapper functions.  */
23
        return (int)gzf;
24
 }
25