?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Blame |
Last modification |
View Log
| RSS feed
Author: James Morrison <phython@debian.org>
Description: Document stupidity of tartype_t in libtar.c.
Bug-Debian: http://bugs.debian.org/309945
--- a/libtar/libtar.c
+++ b/libtar/libtar.c
@@ -19,6 +19,7 @@
#include <sys/param.h>
#ifdef STDC_HEADERS
+# include <stdlib.h>
# include <string.h>
#endif
@@ -91,6 +92,10 @@ gzopen_frontend(char *pathname, int ofla
return -1;
}
+ /* This is a bad thing to do on big-endian lp64 systems, where the
+ size and placement of integers is different than pointers.
+ However, to fix the problem 4 wrapper functions would be needed and
+ an extra bit of data associating GZF with the wrapper functions. */
return (int)gzf;
}