Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
6 magnus 1
Description: Escape hyphens that should be minus signs in man pages.
2
 
3
--- a/doc/tar_append_file.3
4
+++ b/doc/tar_append_file.3
5
@@ -31,7 +31,7 @@ The \fBtar_append_eof\fP() function writ
6
 all zeros) to the tar file associated with \fIt\fP.
7
 .SH RETURN VALUES
8
 On successful completion, these functions will return 0.  On failure,
9
-they will return -1 and set \fIerrno\fP to an appropriate value.
10
+they will return \-1 and set \fIerrno\fP to an appropriate value.
11
 .SH ERRORS
12
 The \fBtar_append_*\fP() functions will fail if:
13
 .IP \fBEINVAL\fP
14
--- a/doc/tar_extract_all.3
15
+++ b/doc/tar_extract_all.3
16
@@ -30,7 +30,7 @@ are modified by replacing \fIrealdir\fP
17
 files will be extracted into \fIsavedir\fP.
18
 .SH RETURN VALUES
19
 On successful completion, these functions will return 0.  On failure,
20
-they will return -1 and set \fIerrno\fP to an appropriate value.
21
+they will return \-1 and set \fIerrno\fP to an appropriate value.
22
 .SH ERRORS
23
 These functions will fail under the same conditions that the
24
 \fBtar_skip_regfile\fP(), \fBtar_extract_regfile\fP(), \fBopendir\fP(),
25
--- a/doc/tar_extract_file.3
26
+++ b/doc/tar_extract_file.3
27
@@ -48,7 +48,7 @@ other \fBtar_extract_*\fP() functions di
28
 \fBtar_set_file_perms\fP() manually if this behavior is desired.
29
 .SH RETURN VALUES
30
 On successful completion, the functions documented here will
31
-return 0.  On failure, they will return -1 and set \fIerrno\fP to an
32
+return 0.  On failure, they will return \-1 and set \fIerrno\fP to an
33
 appropriate value.
34
 
35
 The \fBtar_extract_dir\fP() function will return 1 if the directory
36
--- a/doc/th_print_long_ls.3
37
+++ b/doc/th_print_long_ls.3
38
@@ -12,7 +12,7 @@ This man page documents version 1.2 of \
39
 .SH DESCRIPTION
40
 The \fBth_print_long_ls\fP() function prints a line to \fIstdout\fP which
41
 describes the file pointed to by the current file header associated with
42
-the \fITAR\fP handle \fIt\fP.  The output is similar to that of "ls -l".
43
+the \fITAR\fP handle \fIt\fP.  The output is similar to that of "ls \-l".
44
 
45
 The \fBth_print\fP() function prints the value of each field of the
46
 current file header associated with the \fITAR\fP handle \fIt\fP to
47
--- a/doc/th_read.3
48
+++ b/doc/th_read.3
49
@@ -20,7 +20,7 @@ tar header associated with \fIt\fP to th
50
 with \fIt\fP.
51
 .SH RETURN VALUE
52
 On successful completion, \fBth_read\fP() and \fBth_write\fP() will
53
-return 0.  On failure, they will return -1 and set \fIerrno\fP to an
54
+return 0.  On failure, they will return \-1 and set \fIerrno\fP to an
55
 appropriate value.
56
 
57
 On \fIEOF\fP, \fBth_read\fP() will return 1.
58
--- a/doc/tar_open.3
59
+++ b/doc/tar_open.3
60
@@ -79,7 +79,7 @@ with the \fITAR\fP handle \fIt\fP and fr
61
 memory.
62
 .SH RETURN VALUE
63
 The \fBtar_open\fP(), \fBtar_fdopen\fP(), and \fBtar_close\fP() functions
64
-return 0 on success.  On failure, they return -1 and set \fIerrno\fP.
65
+return 0 on success.  On failure, they return \-1 and set \fIerrno\fP.
66
 
67
 The \fBtar_fd\fP() function returns the file descriptor associated with
68
 the \fITAR\fP handle \fIt\fP.
69
--- a/listhash/hash_new.3.in
70
+++ b/listhash/hash_new.3.in
71
@@ -39,7 +39,7 @@ used to iterate through the hash.  The \
72
 has two fields: \fIbucket\fP, which indicates the current bucket in the
73
 hash, and \fInode\fP, which is a pointer to the current node in the current
74
 bucket.  To start at the beginning or end of the hash, the caller should
75
-initialize \fIhp.bucket\fP to -1 and \fIhp.node\fP to \fINULL\fP.
76
+initialize \fIhp.bucket\fP to \-1 and \fIhp.node\fP to \fINULL\fP.
77
 
78
 The \fB@LISTHASH_PREFIX@_hash_search\fP() function searches iteratively through the
79
 hash \fIh\fP until it finds a node whose contents match \fIdata\fP using
80
@@ -65,10 +65,10 @@ return 1 when valid data is returned, an
81
 The \fB@LISTHASH_PREFIX@_hash_getkey\fP() and \fB@LISTHASH_PREFIX@_hash_search\fP() functions
82
 return 1 when a match is found, or 0 otherwise.
83
 
84
-The \fB@LISTHASH_PREFIX@_hash_add\fP() function returns 0 on success, or -1 on
85
+The \fB@LISTHASH_PREFIX@_hash_add\fP() function returns 0 on success, or \-1 on
86
 error (and sets \fIerrno\fP).
87
 
88
-The \fB@LISTHASH_PREFIX@_hash_del\fP() function returns 0 on success, or -1 on
89
+The \fB@LISTHASH_PREFIX@_hash_del\fP() function returns 0 on success, or \-1 on
90
 error (and sets \fIerrno\fP).
91
 .SH SEE ALSO
92
 .BR @LISTHASH_PREFIX@_list_new (3)
93
--- a/listhash/list_new.3.in
94
+++ b/listhash/list_new.3.in
95
@@ -81,6 +81,6 @@ The \fB@LISTHASH_PREFIX@_list_next\fP(),
96
 returned, or 0 otherwise.
97
 
98
 The \fB@LISTHASH_PREFIX@_list_add\fP() and \fB@LISTHASH_PREFIX@_list_add_str\fP() functions
99
-return 0 on success, or -1 on error.
100
+return 0 on success, or \-1 on error.
101
 .SH SEE ALSO
102
 .BR @LISTHASH_PREFIX@_hash_new (3)