Rev 39 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
39 | magnus | 1 | --- a/Makefile.am |
2 | +++ b/Makefile.am |
||
3 | @@ -10,5 +10,5 @@ ACLOCAL_AMFLAGS = -I autoconf |
||
4 | |||
5 | #@SET_MAKE@ |
||
6 | |||
7 | -SUBDIRS = lib libtar doc |
||
8 | +SUBDIRS = lib libtar doc testsuite |
||
9 | |||
10 | --- a/doc/Makefile.in |
||
11 | +++ b/doc/Makefile.in |
||
12 | @@ -151,3 +151,4 @@ install: all |
||
13 | echo ".so man3/@LISTHASH_PREFIX@_list_new.3" > ${DESTDIR}${mandir}/man3/$${i}.3; \ |
||
14 | done |
||
15 | |||
16 | +check: |
||
17 | --- a/lib/Makefile.in |
||
18 | +++ b/lib/Makefile.in |
||
19 | @@ -104,3 +104,4 @@ install: ${ALL} |
||
20 | ${INSTALL_DATA} ${srcdir}/libtar.h ${DESTDIR}${includedir} |
||
21 | ${INSTALL_DATA} ../listhash/libtar_listhash.h ${DESTDIR}${includedir} |
||
22 | |||
23 | +check: |
||
24 | --- a/libtar/Makefile.in |
||
25 | +++ b/libtar/Makefile.in |
||
26 | @@ -76,3 +76,4 @@ install: ${ALL} |
||
27 | ${MKDIR} ${DESTDIR}${bindir} |
||
28 | $(LIBTOOL) --mode=install ${INSTALL_PROGRAM} libtar ${DESTDIR}${bindir} |
||
29 | |||
30 | +check: |
||
31 | --- /dev/null |
||
50 | magnus | 32 | +++ b/testsuite/Makefile |
33 | @@ -0,0 +1,10 @@ |
||
39 | magnus | 34 | +all: |
35 | + |
||
36 | +check: ../libtar/libtar |
||
37 | + ../libtar/libtar -C ../doc -c test.tar . |
||
38 | + ../libtar/libtar -t test.tar |
||
39 | + $(RM) test.tar |
||
40 | +install: |
||
50 | magnus | 41 | + |
42 | +distclean: |
||
43 | +clean: |