Rev 47 | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 47 | Rev 49 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | 2 | ||
- | 3 | %: |
|
3 | export LIBTOOLIZE = libtoolize --install |
4 | dh $@ |
4 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
- | |
5 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
- | |
6 | 5 | ||
7 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
- | |
8 | ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
- | |
9 | buildflags += --host=$(DEB_HOST_GNU_TYPE) |
- | |
10 | endif |
- | |
11 | - | ||
12 | configure: configure-stamp |
- | |
13 | configure-stamp: |
- | |
14 | dh_testdir |
- | |
15 | [ -f debian/autoreconf.before ] || dh_autoreconf |
- | |
16 | ./configure $(buildflags) \ |
- | |
17 | --prefix=/usr \ |
- | |
18 | --without-zlib \ |
- | |
19 | --mandir=\$${prefix}/share/man \ |
- | |
20 | $(shell dpkg-buildflags --export=configure) |
- | |
21 | touch configure-stamp |
- | |
22 | - | ||
23 | build-arch: build |
- | |
24 | build-indep: |
- | |
25 | build: build-stamp |
- | |
26 | build-stamp: configure-stamp |
- | |
27 | dh_testdir |
- | |
28 | $(MAKE) |
- | |
29 | touch build-stamp |
- | |
30 | - | ||
31 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
- | |
32 | $(MAKE) check |
- | |
33 | endif |
- | |
34 | - | ||
35 | clean: |
- | |
36 | dh_testdir |
- | |
37 | dh_testroot |
- | |
38 | # Stale build files |
- | |
39 | [ ! -f Makefile ] || $(MAKE) distclean |
- | |
40 | -rm -f build-stamp configure-stamp |
- | |
41 | dh_autoreconf_clean |
- | |
42 | dh_clean libtool configure |
6 | override_dh_auto_configure: |
43 | - | ||
44 | install: build-stamp |
- | |
45 | dh_testdir |
- | |
46 | dh_testroot |
- | |
47 | dh_prep |
- | |
48 | - | ||
49 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
- | |
50 | - | ||
51 | binary-indep: |
- | |
52 | - | ||
53 | binary-arch: install |
- | |
54 | dh_testdir |
- | |
55 | dh_testroot |
- | |
56 | dh_install --sourcedir=debian/tmp |
7 | dh_auto_configure -- --without-zlib |
57 | - | ||
58 | dh_installdocs |
- | |
59 | dh_installexamples |
- | |
60 | dh_installman |
- | |
61 | dh_installchangelogs ChangeLog |
- | |
62 | dh_link |
- | |
63 | dh_strip |
- | |
64 | dh_compress |
- | |
65 | dh_fixperms |
- | |
66 | dh_makeshlibs |
- | |
67 | dh_installdeb |
- | |
68 | dh_shlibdeps |
- | |
69 | dh_gencontrol |
- | |
70 | dh_md5sums |
- | |
71 | dh_builddeb |
- | |
72 | - | ||
73 | binary: binary-indep binary-arch |
- | |
74 | .PHONY: build clean binary-indep binary-arch binary install configure |
- |