Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 40 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 40 Rev 47
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
2
3
export LIBTOOLIZE = libtoolize --install
3
export LIBTOOLIZE = libtoolize --install
-
 
4
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
5
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
6
-
 
7
buildflags = --build=$(DEB_BUILD_GNU_TYPE)
-
 
8
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-
 
9
  buildflags += --host=$(DEB_HOST_GNU_TYPE)
-
 
10
endif
4
11
5
configure: configure-stamp
12
configure: configure-stamp
6
configure-stamp:
13
configure-stamp:
7
	dh_testdir
14
	dh_testdir
8
	[ -f debian/autoreconf.before ] || dh_autoreconf
15
	[ -f debian/autoreconf.before ] || dh_autoreconf
9
	./configure \
16
	./configure $(buildflags) \
10
		--prefix=/usr \
17
		--prefix=/usr \
11
	        --without-zlib \
18
	        --without-zlib \
12
		--mandir=\$${prefix}/share/man \
19
		--mandir=\$${prefix}/share/man \
13
		$(shell dpkg-buildflags --export=configure)
20
		$(shell dpkg-buildflags --export=configure)
14
	touch configure-stamp
21
	touch configure-stamp
15
22
16
build-arch: build
23
build-arch: build
17
build-indep:
24
build-indep:
18
build: build-stamp
25
build: build-stamp
19
build-stamp: configure-stamp 
26
build-stamp: configure-stamp 
20
	dh_testdir
27
	dh_testdir
21
	$(MAKE)
28
	$(MAKE)
22
	touch build-stamp
29
	touch build-stamp
23
30
24
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
31
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
25
	$(MAKE) check
32
	$(MAKE) check
26
endif
33
endif
27
34
28
clean:
35
clean:
29
	dh_testdir
36
	dh_testdir
30
	dh_testroot
37
	dh_testroot
31
	# Stale build files
38
	# Stale build files
32
	[ ! -f Makefile ] || $(MAKE) distclean
39
	[ ! -f Makefile ] || $(MAKE) distclean
33
	-rm -f build-stamp configure-stamp
40
	-rm -f build-stamp configure-stamp
34
	dh_autoreconf_clean
41
	dh_autoreconf_clean
35
	dh_clean libtool configure
42
	dh_clean libtool configure
36
43
37
install: build-stamp
44
install: build-stamp
38
	dh_testdir
45
	dh_testdir
39
	dh_testroot
46
	dh_testroot
40
	dh_prep
47
	dh_prep
41
48
42
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
49
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
43
50
44
binary-indep:
51
binary-indep:
45
52
46
binary-arch: install
53
binary-arch: install
47
	dh_testdir
54
	dh_testdir
48
	dh_testroot
55
	dh_testroot
49
	dh_install --sourcedir=debian/tmp
56
	dh_install --sourcedir=debian/tmp
50
57
51
	dh_installdocs
58
	dh_installdocs
52
	dh_installexamples
59
	dh_installexamples
53
	dh_installman 
60
	dh_installman 
54
	dh_installchangelogs ChangeLog
61
	dh_installchangelogs ChangeLog
55
	dh_link
62
	dh_link
56
	dh_strip
63
	dh_strip
57
	dh_compress
64
	dh_compress
58
	dh_fixperms
65
	dh_fixperms
59
	dh_makeshlibs
66
	dh_makeshlibs
60
	dh_installdeb
67
	dh_installdeb
61
	dh_shlibdeps
68
	dh_shlibdeps
62
	dh_gencontrol
69
	dh_gencontrol
63
	dh_md5sums
70
	dh_md5sums
64
	dh_builddeb
71
	dh_builddeb
65
72
66
binary: binary-indep binary-arch
73
binary: binary-indep binary-arch
67
.PHONY: build clean binary-indep binary-arch binary install configure
74
.PHONY: build clean binary-indep binary-arch binary install configure