Rev 3 | Rev 5 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/usr/bin/make -f |
2 | |||
4 | magnus | 3 | export DH_VERBOSE=1 |
3 | magnus | 4 | |
4 | magnus | 5 | configure: |
3 | magnus | 6 | dh_testdir |
4 | magnus | 7 | cp /usr/share/misc/config.* autoconf |
8 | autoreconf -f -v -i |
||
3 | magnus | 9 | ./configure \ |
10 | --prefix=/usr \ |
||
11 | --mandir=\$${prefix}/share/man |
||
12 | touch configure-stamp |
||
13 | |||
4 | magnus | 14 | configure-stamp: configure |
15 | |||
16 | build-stamp: build |
||
17 | |||
18 | build: configure-stamp |
||
3 | magnus | 19 | dh_testdir |
20 | $(MAKE) |
||
21 | touch build-stamp |
||
22 | |||
23 | clean: |
||
24 | dh_testdir |
||
25 | dh_testroot |
||
26 | # Stale build files |
||
4 | magnus | 27 | [ ! -f Makefile ] || $(MAKE) clean |
3 | magnus | 28 | [ ! -f Makefile ] || $(MAKE) distclean |
29 | -rm -f build-stamp configure-stamp |
||
4 | magnus | 30 | -rm -rf config.log autoconf/config.guess autoconf/config.sub autoconf/depcomp autoconf/ltmain.sh autoconf/missing autoconf/mkinstalldirs autom4te.cache libtool |
31 | dh_clean |
||
3 | magnus | 32 | |
33 | install: build-stamp |
||
34 | dh_testdir |
||
35 | dh_testroot |
||
4 | magnus | 36 | dh_installdirs |
3 | magnus | 37 | |
38 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
||
39 | |||
40 | binary-indep: build install |
||
41 | |||
42 | binary-arch: install |
||
43 | dh_testdir |
||
44 | dh_testroot |
||
45 | dh_install --sourcedir=debian/tmp |
||
46 | |||
47 | dh_installdocs |
||
4 | magnus | 48 | dh_installexamples -p libtar-dev libtar/libtar.c libtar/Makefile |
3 | magnus | 49 | dh_installman |
50 | dh_installchangelogs ChangeLog |
||
51 | dh_link |
||
52 | dh_strip |
||
53 | dh_compress |
||
54 | dh_fixperms |
||
55 | dh_makeshlibs |
||
56 | dh_installdeb |
||
57 | dh_shlibdeps |
||
58 | dh_gencontrol |
||
59 | dh_md5sums |
||
60 | dh_builddeb |
||
61 | |||
62 | binary: binary-indep binary-arch |
||
63 | .PHONY: build clean binary-indep binary-arch binary install configure |