Rev 12 | Rev 47 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/usr/bin/make -f |
2 | |||
5 | magnus | 3 | export LIBTOOLIZE = libtoolize --install |
3 | magnus | 4 | |
5 | magnus | 5 | configure: configure-stamp |
6 | configure-stamp: |
||
3 | magnus | 7 | dh_testdir |
5 | magnus | 8 | [ -f debian/autoreconf.before ] || dh_autoreconf |
3 | magnus | 9 | ./configure \ |
10 | --prefix=/usr \ |
||
40 | magnus | 11 | --without-zlib \ |
12 | magnus | 12 | --mandir=\$${prefix}/share/man \ |
13 | $(shell dpkg-buildflags --export=configure) |
||
3 | magnus | 14 | touch configure-stamp |
15 | |||
9 | magnus | 16 | build-arch: build |
17 | build-indep: |
||
5 | magnus | 18 | build: build-stamp |
19 | build-stamp: configure-stamp |
||
3 | magnus | 20 | dh_testdir |
21 | $(MAKE) |
||
22 | touch build-stamp |
||
23 | |||
40 | magnus | 24 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
25 | $(MAKE) check |
||
26 | endif |
||
27 | |||
3 | magnus | 28 | clean: |
29 | dh_testdir |
||
30 | dh_testroot |
||
31 | # Stale build files |
||
32 | [ ! -f Makefile ] || $(MAKE) distclean |
||
33 | -rm -f build-stamp configure-stamp |
||
5 | magnus | 34 | dh_autoreconf_clean |
35 | dh_clean libtool configure |
||
3 | magnus | 36 | |
37 | install: build-stamp |
||
38 | dh_testdir |
||
39 | dh_testroot |
||
5 | magnus | 40 | dh_prep |
3 | magnus | 41 | |
42 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
||
43 | |||
7 | magnus | 44 | binary-indep: |
3 | magnus | 45 | |
46 | binary-arch: install |
||
47 | dh_testdir |
||
48 | dh_testroot |
||
49 | dh_install --sourcedir=debian/tmp |
||
50 | |||
51 | dh_installdocs |
||
5 | magnus | 52 | dh_installexamples |
3 | magnus | 53 | dh_installman |
54 | dh_installchangelogs ChangeLog |
||
55 | dh_link |
||
56 | dh_strip |
||
57 | dh_compress |
||
58 | dh_fixperms |
||
59 | dh_makeshlibs |
||
60 | dh_installdeb |
||
61 | dh_shlibdeps |
||
62 | dh_gencontrol |
||
63 | dh_md5sums |
||
64 | dh_builddeb |
||
65 | |||
66 | binary: binary-indep binary-arch |
||
67 | .PHONY: build clean binary-indep binary-arch binary install configure |