Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 40 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
 
5 magnus 3
export LIBTOOLIZE = libtoolize --install
47 magnus 4
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
5
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
3 magnus 6
 
47 magnus 7
buildflags = --build=$(DEB_BUILD_GNU_TYPE)
8
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
9
  buildflags += --host=$(DEB_HOST_GNU_TYPE)
10
endif
11
 
5 magnus 12
configure: configure-stamp
13
configure-stamp:
3 magnus 14
	dh_testdir
5 magnus 15
	[ -f debian/autoreconf.before ] || dh_autoreconf
47 magnus 16
	./configure $(buildflags) \
3 magnus 17
		--prefix=/usr \
40 magnus 18
	        --without-zlib \
12 magnus 19
		--mandir=\$${prefix}/share/man \
20
		$(shell dpkg-buildflags --export=configure)
3 magnus 21
	touch configure-stamp
22
 
9 magnus 23
build-arch: build
24
build-indep:
5 magnus 25
build: build-stamp
26
build-stamp: configure-stamp
3 magnus 27
	dh_testdir
28
	$(MAKE)
29
	touch build-stamp
30
 
40 magnus 31
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
32
	$(MAKE) check
33
endif
34
 
3 magnus 35
clean:
36
	dh_testdir
37
	dh_testroot
38
	# Stale build files
39
	[ ! -f Makefile ] || $(MAKE) distclean
40
	-rm -f build-stamp configure-stamp
5 magnus 41
	dh_autoreconf_clean
42
	dh_clean libtool configure
3 magnus 43
 
44
install: build-stamp
45
	dh_testdir
46
	dh_testroot
5 magnus 47
	dh_prep
3 magnus 48
 
49
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
50
 
7 magnus 51
binary-indep:
3 magnus 52
 
53
binary-arch: install
54
	dh_testdir
55
	dh_testroot
56
	dh_install --sourcedir=debian/tmp
57
 
58
	dh_installdocs
5 magnus 59
	dh_installexamples
3 magnus 60
	dh_installman
61
	dh_installchangelogs ChangeLog
62
	dh_link
63
	dh_strip
64
	dh_compress
65
	dh_fixperms
66
	dh_makeshlibs
67
	dh_installdeb
68
	dh_shlibdeps
69
	dh_gencontrol
70
	dh_md5sums
71
	dh_builddeb
72
 
73
binary: binary-indep binary-arch
74
.PHONY: build clean binary-indep binary-arch binary install configure