Rev 40 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 40 | Rev 47 | ||
---|---|---|---|
Line 1... | Line 1... | ||
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | 2 | ||
3 | export LIBTOOLIZE = libtoolize --install |
3 | export LIBTOOLIZE = libtoolize --install |
- | 4 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
|
- | 5 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
|
- | 6 | ||
- | 7 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
|
- | 8 | ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
|
- | 9 | buildflags += --host=$(DEB_HOST_GNU_TYPE) |
|
- | 10 | endif |
|
4 | 11 | ||
5 | configure: configure-stamp |
12 | configure: configure-stamp |
6 | configure-stamp: |
13 | configure-stamp: |
7 | dh_testdir |
14 | dh_testdir |
8 | [ -f debian/autoreconf.before ] || dh_autoreconf |
15 | [ -f debian/autoreconf.before ] || dh_autoreconf |
9 | ./configure \ |
16 | ./configure $(buildflags) \ |
10 | --prefix=/usr \ |
17 | --prefix=/usr \ |
11 | --without-zlib \ |
18 | --without-zlib \ |
12 | --mandir=\$${prefix}/share/man \ |
19 | --mandir=\$${prefix}/share/man \ |
13 | $(shell dpkg-buildflags --export=configure) |
20 | $(shell dpkg-buildflags --export=configure) |
14 | touch configure-stamp |
21 | touch configure-stamp |