Rev 4 | Rev 7 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 4 | Rev 5 | ||
---|---|---|---|
Line 1... | Line 1... | ||
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | 2 | ||
3 | export DH_VERBOSE=1 |
3 | export LIBTOOLIZE = libtoolize --install |
4 | 4 | ||
- | 5 | configure: configure-stamp |
|
5 | configure: |
6 | configure-stamp: |
6 | dh_testdir |
7 | dh_testdir |
7 | cp /usr/share/misc/config.* autoconf |
8 | [ -f debian/autoreconf.before ] || dh_autoreconf |
8 | autoreconf -f -v -i |
- | |
9 | ./configure \ |
9 | ./configure \ |
10 | --prefix=/usr \ |
10 | --prefix=/usr \ |
11 | --mandir=\$${prefix}/share/man |
11 | --mandir=\$${prefix}/share/man |
12 | touch configure-stamp |
12 | touch configure-stamp |
13 | 13 | ||
14 | configure-stamp: configure |
- | |
15 | - | ||
16 | build-stamp: build |
14 | build: build-stamp |
17 | - | ||
18 | build: configure-stamp |
15 | build-stamp: configure-stamp |
19 | dh_testdir |
16 | dh_testdir |
20 | $(MAKE) |
17 | $(MAKE) |
21 | touch build-stamp |
18 | touch build-stamp |
22 | 19 | ||
23 | clean: |
20 | clean: |
24 | dh_testdir |
21 | dh_testdir |
25 | dh_testroot |
22 | dh_testroot |
26 | # Stale build files |
23 | # Stale build files |
27 | [ ! -f Makefile ] || $(MAKE) clean |
- | |
28 | [ ! -f Makefile ] || $(MAKE) distclean |
24 | [ ! -f Makefile ] || $(MAKE) distclean |
29 | -rm -f build-stamp configure-stamp |
25 | -rm -f build-stamp configure-stamp |
30 | -rm -rf config.log autoconf/config.guess autoconf/config.sub autoconf/depcomp autoconf/ltmain.sh autoconf/missing autoconf/mkinstalldirs autom4te.cache libtool |
- | |
31 | dh_clean |
26 | dh_autoreconf_clean |
- | 27 | dh_clean libtool configure |
|
32 | 28 | ||
33 | install: build-stamp |
29 | install: build-stamp |
34 | dh_testdir |
30 | dh_testdir |
35 | dh_testroot |
31 | dh_testroot |
36 | dh_installdirs |
32 | dh_prep |
37 | 33 | ||
38 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
34 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
39 | 35 | ||
40 | binary-indep: build install |
36 | binary-indep: build install |
41 | 37 | ||
Line 43... | Line 39... | ||
43 | dh_testdir |
39 | dh_testdir |
44 | dh_testroot |
40 | dh_testroot |
45 | dh_install --sourcedir=debian/tmp |
41 | dh_install --sourcedir=debian/tmp |
46 | 42 | ||
47 | dh_installdocs |
43 | dh_installdocs |
48 | dh_installexamples -p libtar-dev libtar/libtar.c libtar/Makefile |
44 | dh_installexamples |
49 | dh_installman |
45 | dh_installman |
50 | dh_installchangelogs ChangeLog |
46 | dh_installchangelogs ChangeLog |
51 | dh_link |
47 | dh_link |
52 | dh_strip |
48 | dh_strip |
53 | dh_compress |
49 | dh_compress |