Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 47 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 47 Rev 55
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
2
3
include /usr/share/cdbs/1/class/autotools.mk
3
include /usr/share/cdbs/1/class/autotools.mk
4
include /usr/share/cdbs/1/rules/debhelper.mk
4
include /usr/share/cdbs/1/rules/debhelper.mk
5
include /usr/share/cdbs/1/rules/dpatch.mk
5
include /usr/share/cdbs/1/rules/dpatch.mk
6
6
7
# the used configure parameters for ./configure
7
# the used configure parameters for ./configure
8
DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \
8
DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \
9
	--with-pty --enable-tcp-forward --enable-x11-forward \
9
	--with-pty --enable-tcp-forward --enable-x11-forward \
10
	--enable-agent-forward --enable-ipv6 --enable-utmp \
10
	--enable-agent-forward --enable-ipv6 --enable-utmp \
11
	--with-zlib --with-tcpwrappers --libexecdir=/usr/lib/lsh \
11
	--with-zlib --with-tcpwrappers --libexecdir=/usr/lib/lsh \
12
	--with-x --with-system-nettle --with-system-argp \
12
	--with-x --with-system-nettle --with-system-argp \
13
	XAUTH_PROGRAM=/usr/bin/xauth
13
	XAUTH_PROGRAM=/usr/bin/xauth
14
14
15
DEB_INSTALL_CHANGELOGS_ALL := ChangeLog
15
DEB_INSTALL_CHANGELOGS_ALL := ChangeLog
16
DEB_INSTALL_DOCS_ALL := README
16
DEB_INSTALL_DOCS_ALL := README
17
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
17
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
18
18
19
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
19
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
20
-
 
21
common-install-arch::
-
 
22
	install -m755 debian/scripts/lsh-server-config \
-
 
23
		debian/tmp/usr/sbin
-