Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 29 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
 
3
include /usr/share/cdbs/1/class/autotools.mk
4
include /usr/share/cdbs/1/rules/debhelper.mk
29 magnus 5
include /usr/share/cdbs/1/rules/dpatch.mk
2 magnus 6
 
7
# the used configure parameters for ./configure
8
DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \
9
	--with-pty --enable-tcp-forward --enable-x11-forward \
10
	--enable-agent-forward --enable-ipv6 --enable-utmp \
47 magnus 11
	--with-zlib --with-tcpwrappers --libexecdir=/usr/lib/lsh \
12
	--with-x --with-system-nettle --with-system-argp \
13
	XAUTH_PROGRAM=/usr/bin/xauth
2 magnus 14
 
29 magnus 15
DEB_INSTALL_CHANGELOGS_ALL := ChangeLog
16
DEB_INSTALL_DOCS_ALL := README
17
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
2 magnus 18
 
29 magnus 19
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
2 magnus 20
 
29 magnus 21
common-install-arch::
2 magnus 22
	install -m755 debian/scripts/lsh-server-config \
29 magnus 23
		debian/tmp/usr/sbin