Rev 2 | Rev 61 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 2 | Rev 40 | ||
---|---|---|---|
Line 55... | Line 55... | ||
55 | db_get "lsh-server/sftp"; ENABLE_SFTP="$RET" |
55 | db_get "lsh-server/sftp"; ENABLE_SFTP="$RET" |
56 | 56 | ||
57 | # OK, now make the config file |
57 | # OK, now make the config file |
58 | 58 | ||
59 | cat <<"EOF" >"$LSHD_DEFAULTS" |
59 | cat <<"EOF" >"$LSHD_DEFAULTS" |
60 | # Configuration file generated by lsh-server-config. |
60 | # Configuration file generated by lsh-server.postinst. |
61 | # You can change the lsh-server configuration either by editing |
61 | # You can change the lsh-server configuration either by editing |
62 | # this file, or by running /usr/sbin/lsh-server-config, which uses |
62 | # this file, or by running dpkg-reconfigure lsh-server. |
63 | # a debconf interface to set up lsh-server. |
- | |
64 | # |
63 | # |
65 | EOF |
64 | EOF |
66 | 65 | ||
67 | echo "LSHD_PORT=\"$LSHD_PORT\"" >>"$LSHD_DEFAULTS" |
66 | echo "LSHD_PORT=\"$LSHD_PORT\"" >>"$LSHD_DEFAULTS" |
68 | echo "ENABLE_SFTP=\"$ENABLE_SFTP\"" >> "$LSHD_DEFAULTS" |
67 | echo "ENABLE_SFTP=\"$ENABLE_SFTP\"" >> "$LSHD_DEFAULTS" |
Line 86... | Line 85... | ||
86 | file=/etc/ssh/sshd_not_to_be_run |
85 | file=/etc/ssh/sshd_not_to_be_run |
87 | if [ ! -f "$file" ] ; then |
86 | if [ ! -f "$file" ] ; then |
88 | # stop ssh from starting at bootup |
87 | # stop ssh from starting at bootup |
89 | cat <<"EOF" >"$file" |
88 | cat <<"EOF" >"$file" |
90 | LSH_SERVER_CONFIG_GENERATED |
89 | LSH_SERVER_CONFIG_GENERATED |
91 | # Generated by lsh-server-config |
90 | # Generated by lsh-server.postinst |
92 | # Please don't remove this file unless you have first disabled lsh, and don't |
91 | # Please don't remove this file unless you have first disabled lsh, and don't |
93 | # change the first line ... otherwise lsh-server won't recognise it!!! |
92 | # change the first line ... otherwise lsh-server won't recognise it!!! |
94 | EOF |
93 | EOF |
95 | fi |
94 | fi |
96 | fi |
95 | fi |