Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh
2
# postinst script for lsh-utils
3
#
4
# see: dh_installdeb(1)
5
#
6
#
7
 
8
set -e
9
 
10
# summary of how this script can be called:
11
#        * <postinst> `configure' <most-recently-configured-version>
12
#        * <old-postinst> `abort-upgrade' <new version>
13
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
14
#          <new-version>
15
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
16
#          <failed-install-package> <version> `removing'
17
#          <conflicting-package> <version>
18
# for details, see http://www.debian.org/doc/debian-policy/ or
19
# the debian-policy package
20
#
21
# quoting from the policy:
22
#     Any necessary prompting should almost always be confined to the
23
#     post-installation script, and should be protected with a conditional
24
#     so that unnecessary prompting doesn't happen if a package's
25
#     installation fails and the `postinst' is called with `abort-upgrade',
26
#     `abort-remove' or `abort-deconfigure'.
27
 
28
case "$1" in
29
    configure)
30
    /usr/sbin/update-alternatives --install /usr/bin/sexp-conv sexp-conv /usr/bin/sexp-conv.lsh-utils 9 \
31
    --slave /usr/share/man/man1/sexp-conv.1.gz sexp-conv.1.gz /usr/share/man/man1/sexp-conv.lsh-utils.1.gz
32
    ;;
33
 
34
    abort-upgrade|abort-remove|abort-deconfigure)
35
 
36
    ;;
37
 
38
    *)
39
        echo "postinst called with unknown argument \`$1'" >&2
40
        exit 1
41
    ;;
42
esac
43
 
44
# dh_installdeb will replace this with shell code automatically
45
# generated by other debhelper scripts.
46
 
47
#DEBHELPER#
48
 
49
exit 0