Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
126 | magnus | 1 | Description: In testsuite/tcpconnect, treat ECONNRESET as a correct connection shutdown. |
2 | Seems to be necessary on BSD kernels. |
||
3 | |||
4 | diff --git a/src/testsuite/tcpconnect.c b/src/testsuite/tcpconnect.c |
||
5 | index 73398ae..c7dfa02 100644 |
||
6 | --- a/src/testsuite/tcpconnect.c |
||
7 | +++ b/src/testsuite/tcpconnect.c |
||
8 | @@ -307,7 +307,8 @@ main (int argc, char **argv) |
||
9 | wait_stdin_eof = 0; |
||
10 | if (!wait_remote_eof) |
||
11 | break; |
||
12 | - if (shutdown (fd, SHUT_WR) < 0 && errno != ENOTCONN) |
||
13 | + if (shutdown (fd, SHUT_WR) < 0 |
||
14 | + && errno != ENOTCONN && errno != ECONNRESET) |
||
15 | die("shutdown failed: %s\n", strerror(errno)); |
||
16 | } |
||
17 | else |