Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
149 | magnus | 1 | Description: Adjust dummy.c to match type changes in nettle 3.4. |
2 | Author: Niels Möller <nisse@lysator.liu.se> |
||
3 | Bug-Debian: https://bugs.debian.org/884403 |
||
4 | |||
5 | diff --git a/src/dummy.c b/src/dummy.c |
||
6 | index c33c8869..72fd5185 100644 |
||
7 | --- a/src/dummy.c |
||
8 | +++ b/src/dummy.c |
||
9 | @@ -113,14 +113,14 @@ base64_encode_init(struct base64_encode_ctx *ctx UNUSED) |
||
10 | |||
11 | size_t |
||
12 | base64_encode_update(struct base64_encode_ctx *ctx UNUSED, |
||
13 | - uint8_t *dst UNUSED, |
||
14 | + char *dst UNUSED, |
||
15 | size_t length UNUSED, |
||
16 | const uint8_t *src UNUSED) |
||
17 | { abort(); } |
||
18 | |||
19 | size_t |
||
20 | base64_encode_final(struct base64_encode_ctx *ctx UNUSED, |
||
21 | - uint8_t *dst UNUSED) |
||
22 | + char *dst UNUSED) |
||
23 | { abort(); } |
||
24 | |||
25 | void |
||
26 | @@ -132,7 +132,7 @@ base64_decode_update(struct base64_decode_ctx *ctx UNUSED, |
||
27 | size_t *dst_length UNUSED, |
||
28 | uint8_t *dst UNUSED, |
||
29 | size_t src_length UNUSED, |
||
30 | - const uint8_t *src UNUSED) |
||
31 | + const char *src UNUSED) |
||
32 | { abort(); } |
||
33 | |||
34 | int |