Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Blame | Last modification | View Log | RSS feed

Description: Adjust dummy.c to match type changes in nettle 3.4.
Author: Niels Möller <nisse@lysator.liu.se>
Bug-Debian: https://bugs.debian.org/884403

diff --git a/src/dummy.c b/src/dummy.c
index c33c8869..72fd5185 100644
--- a/src/dummy.c
+++ b/src/dummy.c
@@ -113,14 +113,14 @@ base64_encode_init(struct base64_encode_ctx *ctx UNUSED)
 
 size_t
 base64_encode_update(struct base64_encode_ctx *ctx UNUSED,
-                    uint8_t *dst UNUSED,
+                    char *dst UNUSED,
                     size_t length UNUSED,
                     const uint8_t *src UNUSED)
 { abort(); }
 
 size_t
 base64_encode_final(struct base64_encode_ctx *ctx UNUSED,
-                   uint8_t *dst UNUSED)
+                   char *dst UNUSED)
 { abort(); }
 
 void
@@ -132,7 +132,7 @@ base64_decode_update(struct base64_decode_ctx *ctx UNUSED,
                     size_t *dst_length UNUSED,
                     uint8_t *dst UNUSED,
                     size_t src_length UNUSED,
-                    const uint8_t *src UNUSED)
+                    const char *src UNUSED)
 { abort(); }
 
 int