Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 34 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
79 magnus 1
--- a/configure.ac
2
+++ b/configure.ac
3
@@ -778,7 +778,6 @@ if test x$enable_ipv6 = xyes ; then
4
 fi
5
 
6
 AC_CONFIG_SUBDIRS(src/argp)
7
-AC_CONFIG_SUBDIRS(src/nettle)
8
 AC_CONFIG_SUBDIRS(src/spki)
9
 AC_CONFIG_SUBDIRS(src/sftp)
10
 
11
--- a/src/Makefile.am
12
+++ b/src/Makefile.am
13
@@ -1,15 +1,12 @@
14
 # Process this file with automake to produce Makefile.in
15
 
16
-SUBDIRS = argp rsync nettle scm sftp spki . testsuite
17
+SUBDIRS = argp rsync scm sftp spki . testsuite
18
 
19
 include .dist_classes
20
 include .dist_headers
21
 
22
 BUILT_SOURCES = environ.h
23
 
24
-# Kludge needed for finding the nettle/nettle-types.h file in the build tree
25
-AM_CPPFLAGS = -I./nettle
26
-
27
 SCHEME = $(SCHEME_PROGRAM) -l $(srcdir)/scm/$(SCHEME_NAME)-compat.scm
28
 
29
 EXTRA_PROGRAMS = lsh-krb-checkpw lsh-pam-checkpw srp-gen
30
@@ -116,7 +113,7 @@ lsh_krb_checkpw_LDADD=@KRB_LIBS@
31
 
32
 lsh_execuv_LDADD=
33
 
34
-LDADD = liblsh.a spki/libspki.a nettle/libnettle.a @LIBARGP@
35
+LDADD = liblsh.a spki/libspki.a -lnettle @LIBARGP@
36
 
37
 # To avoid having to link lshg with nettle, link with dummy.o.
38
 
39
--- a/src/rsync/Makefile.am
40
+++ b/src/rsync/Makefile.am
41
@@ -3,10 +3,6 @@
42
 noinst_LIBRARIES = librsync.a
43
 noinst_HEADERS = rsync.h
44
 
45
-# Needed for finding the nettle include files in the source tree
46
-# and nettle-types.h in the build tree.
47
-AM_CPPFLAGS = -I$(srcdir)/.. -I../nettle
48
-
49
 librsync_a_SOURCES = generate.c receive.c checksum.c send.c
50
 
51
 
52
--- a/src/sftp/Makefile.am
53
+++ b/src/sftp/Makefile.am
54
@@ -1,8 +1,5 @@
55
 SUBDIRS = . testsuite
56
 
57
-# Needed for finding nettle-types.h in the build tree.
58
-AM_CPPFLAGS = -I..
59
-
60
 AUTOMAKE_OPTIONS = foreign
61
 
62
 bin_PROGRAMS = lsftp
63
--- a/src/spki/Makefile.am
64
+++ b/src/spki/Makefile.am
65
@@ -1,8 +1,5 @@
66
 SUBDIRS = . tools testsuite
67
 
68
-# FIXME: Create a link to nettle directory instead?
69
-AM_CPPFLAGS = -I$(srcdir)/.. -I../nettle
70
-
71
 noinst_LIBRARIES = libspki.a
72
 # libspkiincludedir = $(includedir)/nettle
73
 
74
--- a/src/spki/testsuite/Makefile.am
75
+++ b/src/spki/testsuite/Makefile.am
76
@@ -1,8 +1,4 @@
77
 
78
-# FIXME: Create a link to nettle directory instead?
79
-AM_CPPFLAGS = -O0 -I$(top_srcdir) -I$(top_srcdir)/.. -I../../nettle
80
-AM_LDFLAGS = -L../../nettle
81
-
82
 TS_PROGS = principal-test date-test tag-test read-acl-test \
83
           lookup-acl-test read-cert-test cdsa-reduce-test
84
 
85
--- a/src/spki/tools/Makefile.am
86
+++ b/src/spki/tools/Makefile.am
87
@@ -1,16 +1,12 @@
88
 noinst_PROGRAMS = spki-check-signature spki-make-signature \
89
        spki-delegate spki-reduce
90
 
91
-# FIXME: Create a link to nettle directory instead?
92
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/.. -I../../nettle
93
-AM_LDFLAGS = -L.. -L../../nettle/
94
-
95
 # libnettle.a and libspki.a are added at the end to make sure all
96
 # programs depend on it. It seems there's no DEPENDENCIES variable
97
 # that affects all programs.
98
 
99
 LDADD = misc.o getopt.o getopt1.o \
100
-       -lspki -lnettle ../libspki.a ../../nettle/libnettle.a
101
+       ../libspki.a -lnettle
102
 
103
 spki_make_signature_SOURCES = spki-make-signature.c sign.c
104
 spki_delegate_SOURCES = spki-delegate.c sign.c
105
--- a/src/testsuite/Makefile.am
106
+++ b/src/testsuite/Makefile.am
107
@@ -3,7 +3,7 @@
108
 # -O0 is not recogniced on AIX
109
 # AM_CFLAGS = -O0
110
 
111
-AM_CPPFLAGS = -I$(srcdir)/.. -I.. -I../nettle
112
+AM_CPPFLAGS = -I$(srcdir)/..
113
 
114
 TS_PROGS = arcfour-test aes-test blowfish-test cast128-test \
115
           des-test \
116
@@ -34,7 +34,7 @@ noinst_PROGRAMS = $(TS_PROGS)
117
 # Workaround to get automake to keep dependencies for testutils.o
118
 EXTRA_PROGRAMS = testutils
119
 
120
-LDADD = testutils.o ../liblsh.a ../spki/libspki.a ../nettle/libnettle.a \
121
+LDADD = testutils.o ../liblsh.a ../spki/libspki.a -lnettle \
122
        $(DOTDOT_LIBARGP)
123
 
124
 include .dist_rapid7
125
@@ -59,6 +59,6 @@ all:
126
 
127
 # sexp-conv may be dynamically linked
128
 check: $(TS_ALL)
129
-       LD_LIBRARY_PATH="`pwd`/../nettle/.lib" srcdir=$(srcdir) \
130
+       srcdir=$(srcdir) \
131
                $(srcdir)/run-tests $(TS_ALL)
132
 
133
--- a/src/spki/testsuite/check-signature-test
134
+++ b/src/spki/testsuite/check-signature-test
135
@@ -1,7 +1,7 @@
136
 #! /bin/sh
137
 
138
 conv () {
139
-    echo "$1" | ../../nettle/tools/sexp-conv -s transport | tee test.in
140
+    echo "$1" | sexp-conv -s transport | tee test.in
141
 }
142
 
143
 die () {
144
--- a/src/spki/testsuite/delegate-test
145
+++ b/src/spki/testsuite/delegate-test
146
@@ -1,7 +1,7 @@
147
 #! /bin/sh
148
 
149
 conv () {
150
-    ../../nettle/tools/sexp-conv -s transport | tee test.in
151
+    sexp-conv -s transport | tee test.in
152
 }
153
 
154
 die () {
155
@@ -12,7 +12,7 @@ die () {
156
 check_sexp () {
157
     file="$1"
158
     shift
159
-    ../../nettle/tools/sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
160
+    sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
161
     cmp "$file" test.canonical || die "$@"
162
 }
163
 
164
--- a/src/spki/testsuite/make-signature-test
165
+++ b/src/spki/testsuite/make-signature-test
166
@@ -1,7 +1,7 @@
167
 #! /bin/sh
168
 
169
 conv () {
170
-    echo "$1" | ../../nettle/tools/sexp-conv -s transport | tee test.in
171
+    echo "$1" | sexp-conv -s transport | tee test.in
172
 }
173
 
174
 die () {
175
@@ -10,7 +10,7 @@ die () {
176
 }
177
 
178
 echo foo | ../tools/spki-make-signature "$srcdir/key-1" \
179
-         | ../../nettle/tools/sexp-conv -s transport > test.in
180
+         | sexp-conv -s transport > test.in
181
 
182
 echo foo | ../tools/spki-check-signature "`cat test.in`" \
183
      || die "Valid signature failed"
184
--- a/src/spki/testsuite/reduce-test
185
+++ b/src/spki/testsuite/reduce-test
186
@@ -3,7 +3,7 @@
187
 # Test case from Oscar Cánovas Reverte
188
 
189
 conv () {
190
-    ../../nettle/tools/sexp-conv -s transport
191
+    sexp-conv -s transport
192
 }
193
 
194
 die () {
195
@@ -14,7 +14,7 @@ die () {
196
 check_sexp () {
197
     file="$1"
198
     shift
199
-    ../../nettle/tools/sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
200
+    sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
201
     cmp "$file" test.canonical || die "$@"
202
 }
203
 
204
--- a/src/testsuite/functions.sh
205
+++ b/src/testsuite/functions.sh
206
@@ -9,7 +9,7 @@ set -e
207
 : ${LSH_YARROW_SEED_FILE:="$TEST_HOME/.lsh/yarrow-seed-file"}
208
 
209
 # For lsh-authorize
210
-: ${SEXP_CONV:="`pwd`/../nettle/tools/sexp-conv"}
211
+: ${SEXP_CONV:="sexp-conv"}
212
 
213
 export LSH_YARROW_SEED_FILE SEXP_CONV
214