Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 34 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- a/configure.ac
+++ b/configure.ac
@@ -778,7 +778,6 @@ if test x$enable_ipv6 = xyes ; then
 fi
 
 AC_CONFIG_SUBDIRS(src/argp)
-AC_CONFIG_SUBDIRS(src/nettle)
 AC_CONFIG_SUBDIRS(src/spki)
 AC_CONFIG_SUBDIRS(src/sftp)
 
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,15 +1,12 @@
 # Process this file with automake to produce Makefile.in
 
-SUBDIRS = argp rsync nettle scm sftp spki . testsuite
+SUBDIRS = argp rsync scm sftp spki . testsuite
 
 include .dist_classes
 include .dist_headers
 
 BUILT_SOURCES = environ.h
 
-# Kludge needed for finding the nettle/nettle-types.h file in the build tree
-AM_CPPFLAGS = -I./nettle
-
 SCHEME = $(SCHEME_PROGRAM) -l $(srcdir)/scm/$(SCHEME_NAME)-compat.scm
 
 EXTRA_PROGRAMS = lsh-krb-checkpw lsh-pam-checkpw srp-gen
@@ -116,7 +113,7 @@ lsh_krb_checkpw_LDADD=@KRB_LIBS@
 
 lsh_execuv_LDADD=
 
-LDADD = liblsh.a spki/libspki.a nettle/libnettle.a @LIBARGP@
+LDADD = liblsh.a spki/libspki.a -lnettle @LIBARGP@
 
 # To avoid having to link lshg with nettle, link with dummy.o.
 
--- a/src/rsync/Makefile.am
+++ b/src/rsync/Makefile.am
@@ -3,10 +3,6 @@
 noinst_LIBRARIES = librsync.a
 noinst_HEADERS = rsync.h
 
-# Needed for finding the nettle include files in the source tree
-# and nettle-types.h in the build tree.
-AM_CPPFLAGS = -I$(srcdir)/.. -I../nettle
-
 librsync_a_SOURCES = generate.c receive.c checksum.c send.c
 
 
--- a/src/sftp/Makefile.am
+++ b/src/sftp/Makefile.am
@@ -1,8 +1,5 @@
 SUBDIRS = . testsuite
 
-# Needed for finding nettle-types.h in the build tree.
-AM_CPPFLAGS = -I..
-
 AUTOMAKE_OPTIONS = foreign
 
 bin_PROGRAMS = lsftp
--- a/src/spki/Makefile.am
+++ b/src/spki/Makefile.am
@@ -1,8 +1,5 @@
 SUBDIRS = . tools testsuite
 
-# FIXME: Create a link to nettle directory instead?
-AM_CPPFLAGS = -I$(srcdir)/.. -I../nettle
-
 noinst_LIBRARIES = libspki.a
 # libspkiincludedir = $(includedir)/nettle
 
--- a/src/spki/testsuite/Makefile.am
+++ b/src/spki/testsuite/Makefile.am
@@ -1,8 +1,4 @@
 
-# FIXME: Create a link to nettle directory instead?
-AM_CPPFLAGS = -O0 -I$(top_srcdir) -I$(top_srcdir)/.. -I../../nettle
-AM_LDFLAGS = -L../../nettle
-
 TS_PROGS = principal-test date-test tag-test read-acl-test \
           lookup-acl-test read-cert-test cdsa-reduce-test
 
--- a/src/spki/tools/Makefile.am
+++ b/src/spki/tools/Makefile.am
@@ -1,16 +1,12 @@
 noinst_PROGRAMS = spki-check-signature spki-make-signature \
        spki-delegate spki-reduce
 
-# FIXME: Create a link to nettle directory instead?
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/.. -I../../nettle
-AM_LDFLAGS = -L.. -L../../nettle/
-
 # libnettle.a and libspki.a are added at the end to make sure all
 # programs depend on it. It seems there's no DEPENDENCIES variable
 # that affects all programs.
 
 LDADD = misc.o getopt.o getopt1.o \
-       -lspki -lnettle ../libspki.a ../../nettle/libnettle.a
+       ../libspki.a -lnettle
 
 spki_make_signature_SOURCES = spki-make-signature.c sign.c
 spki_delegate_SOURCES = spki-delegate.c sign.c
--- a/src/testsuite/Makefile.am
+++ b/src/testsuite/Makefile.am
@@ -3,7 +3,7 @@
 # -O0 is not recogniced on AIX
 # AM_CFLAGS = -O0
 
-AM_CPPFLAGS = -I$(srcdir)/.. -I.. -I../nettle
+AM_CPPFLAGS = -I$(srcdir)/..
 
 TS_PROGS = arcfour-test aes-test blowfish-test cast128-test \
           des-test \
@@ -34,7 +34,7 @@ noinst_PROGRAMS = $(TS_PROGS)
 # Workaround to get automake to keep dependencies for testutils.o
 EXTRA_PROGRAMS = testutils
 
-LDADD = testutils.o ../liblsh.a ../spki/libspki.a ../nettle/libnettle.a \
+LDADD = testutils.o ../liblsh.a ../spki/libspki.a -lnettle \
        $(DOTDOT_LIBARGP)
 
 include .dist_rapid7
@@ -59,6 +59,6 @@ all:
 
 # sexp-conv may be dynamically linked
 check: $(TS_ALL)
-       LD_LIBRARY_PATH="`pwd`/../nettle/.lib" srcdir=$(srcdir) \
+       srcdir=$(srcdir) \
                $(srcdir)/run-tests $(TS_ALL)
 
--- a/src/spki/testsuite/check-signature-test
+++ b/src/spki/testsuite/check-signature-test
@@ -1,7 +1,7 @@
 #! /bin/sh
 
 conv () {
-    echo "$1" | ../../nettle/tools/sexp-conv -s transport | tee test.in
+    echo "$1" | sexp-conv -s transport | tee test.in
 }
 
 die () {
--- a/src/spki/testsuite/delegate-test
+++ b/src/spki/testsuite/delegate-test
@@ -1,7 +1,7 @@
 #! /bin/sh
 
 conv () {
-    ../../nettle/tools/sexp-conv -s transport | tee test.in
+    sexp-conv -s transport | tee test.in
 }
 
 die () {
@@ -12,7 +12,7 @@ die () {
 check_sexp () {
     file="$1"
     shift
-    ../../nettle/tools/sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
+    sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
     cmp "$file" test.canonical || die "$@"
 }
     
--- a/src/spki/testsuite/make-signature-test
+++ b/src/spki/testsuite/make-signature-test
@@ -1,7 +1,7 @@
 #! /bin/sh
 
 conv () {
-    echo "$1" | ../../nettle/tools/sexp-conv -s transport | tee test.in
+    echo "$1" | sexp-conv -s transport | tee test.in
 }
 
 die () {
@@ -10,7 +10,7 @@ die () {
 }
 
 echo foo | ../tools/spki-make-signature "$srcdir/key-1" \
-         | ../../nettle/tools/sexp-conv -s transport > test.in
+         | sexp-conv -s transport > test.in
 
 echo foo | ../tools/spki-check-signature "`cat test.in`" \
      || die "Valid signature failed"
--- a/src/spki/testsuite/reduce-test
+++ b/src/spki/testsuite/reduce-test
@@ -3,7 +3,7 @@
 # Test case from Oscar Cánovas Reverte
 
 conv () {
-    ../../nettle/tools/sexp-conv -s transport
+    sexp-conv -s transport
 }
 
 die () {
@@ -14,7 +14,7 @@ die () {
 check_sexp () {
     file="$1"
     shift
-    ../../nettle/tools/sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
+    sexp-conv -s canonical > test.canonical || die "sexp-conv failed"
     cmp "$file" test.canonical || die "$@"
 }
 
--- a/src/testsuite/functions.sh
+++ b/src/testsuite/functions.sh
@@ -9,7 +9,7 @@ set -e
 : ${LSH_YARROW_SEED_FILE:="$TEST_HOME/.lsh/yarrow-seed-file"}
 
 # For lsh-authorize
-: ${SEXP_CONV:="`pwd`/../nettle/tools/sexp-conv"}
+: ${SEXP_CONV:="sexp-conv"}
 
 export LSH_YARROW_SEED_FILE SEXP_CONV