Rev 71 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
79 | magnus | 1 | Author: Magnus Holmgren <holmgren@debian.org> |
2 | Description: Call exit() in lsh's default exception handler on EXC_IO_CONNECT |
||
3 | Otherwise lsh won't terminate. |
||
71 | magnus | 4 | |
5 | diff -urNad trunk~/src/lsh.c trunk/src/lsh.c |
||
6 | --- trunk~/src/lsh.c 2005-03-16 21:06:23.000000000 +0100 |
||
7 | +++ trunk/src/lsh.c 2010-01-09 22:32:51.000000000 +0100 |
||
8 | @@ -959,6 +959,8 @@ |
||
9 | *self->status = EXIT_FAILURE; |
||
10 | |||
11 | werror("%z, (errno = %i)\n", e->msg, exc->error); |
||
12 | + if (e->type == EXC_IO_CONNECT) |
||
13 | + exit(*self->status); |
||
14 | } |
||
15 | else |
||
16 | switch(e->type) |