Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
71 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## terminate_on_connection_failure.dpatch by Magnus Holmgren <holmgren@debian.org>
3
##
4
## DP: Call exit() in lsh's default exception handler on EXC_IO_CONNECT; otherwise
5
## DP: lsh won't terminate.
6
 
7
@DPATCH@
8
diff -urNad trunk~/src/lsh.c trunk/src/lsh.c
9
--- trunk~/src/lsh.c	2005-03-16 21:06:23.000000000 +0100
10
+++ trunk/src/lsh.c	2010-01-09 22:32:51.000000000 +0100
11
@@ -959,6 +959,8 @@
12
       *self->status = EXIT_FAILURE;
13
 
14
       werror("%z, (errno = %i)\n", e->msg, exc->error);
15
+      if (e->type == EXC_IO_CONNECT)
16
+	exit(*self->status);
17
     }
18
   else
19
     switch(e->type)