Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
85 magnus 1
Description: Tell mini-inetd to bind to 127.0.0.1 instead of "localhost".
2
 When told to bind to "localhost", mini-inetd seems to bind to 255.255.255.255.
3
Author: Magnus Holmgren <holmgren@debian.org>
4
 
5
--- a/src/testsuite/functions.sh
6
+++ b/src/testsuite/functions.sh
7
@@ -155,7 +155,7 @@ spawn_lshg () {
8
 # at_connect local-port max-connections shell-command
9
 at_connect () {
10
     # sleep 1 # Allow some time for earlier processes to die
11
-    mini-inetd -m $2 -- localhost:$1 /bin/sh sh -c "$3" &
12
+    mini-inetd -m $2 -- 127.0.0.1:$1 /bin/sh sh -c "$3" &
13
     at_exit "kill $!"
14
 }
15