Rev 79 | Rev 85 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 79 | Rev 83 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
5 | 5 | ||
6 | # Uncomment this to turn on verbose mode. |
6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
7 | #export DH_VERBOSE=1 |
8 | 8 | ||
9 | # These are used for cross-compiling and for saving the configure script |
9 | # These are used for cross-compiling and for saving the configure script |
10 | # from having to guess our platform (since we know it already) |
10 | # from having to guess our platform (since we know it already) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
13 | 13 | ||
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
16 | else |
16 | else |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
18 | endif |
18 | endif |
19 | 19 | ||
20 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
20 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
21 | ifneq (,$(parallel)) |
21 | ifneq (,$(parallel)) |
22 | jobsflag = -j$(parallel) |
22 | jobsflag = -j$(parallel) |
23 | endif |
23 | endif |
24 | 24 | ||
25 | config.status: configure.ac |
25 | config.status: configure.ac |
26 | dh_testdir |
26 | dh_testdir |
27 | # Add here commands to configure the package. |
27 | # Add here commands to configure the package. |
28 | [ -d src/nettle-dontuse -a ! -d src/nettle ] || mv src/nettle src/nettle-dontuse |
28 | [ -d src/nettle-dontuse -a ! -d src/nettle ] || mv src/nettle src/nettle-dontuse |
29 | dh_autoreconf |
29 | dh_autoreconf |
30 | ./configure $(buildflags) \ |
30 | ./configure $(buildflags) \ |
31 | --prefix=/usr \ |
31 | --prefix=/usr \ |
32 | --libdir=/usr/lib \ |
32 | --libdir=/usr/lib \ |
33 | --disable-dependency-tracking \ |
33 | --disable-dependency-tracking \ |
34 | --enable-pam --enable-kerberos --enable-srp \ |
34 | --enable-pam --enable-kerberos --enable-srp \ |
35 | --with-pty --enable-tcp-forward --enable-x11-forward \ |
35 | --with-pty --enable-tcp-forward --enable-x11-forward \ |
36 | --enable-agent-forward --enable-ipv6 --enable-utmp \ |
36 | --enable-agent-forward --enable-ipv6 --enable-utmp \ |
37 | --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \ |
37 | --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \ |
38 | --with-x XAUTH_PROGRAM=/usr/bin/xauth \ |
38 | --with-x XAUTH_PROGRAM=/usr/bin/xauth \ |
39 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,-z,defs -Wl,--as-needed" |
39 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,-z,defs -Wl,--as-needed" |
40 | 40 | ||
41 | build: build-stamp |
41 | build: build-stamp |
42 | build-stamp: config.status |
42 | build-stamp: config.status |
43 | dh_testdir |
43 | dh_testdir |
44 | 44 | ||
45 | # Add here commands to compile the package. |
45 | # Add here commands to compile the package. |
46 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
46 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
47 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
- | |
48 | $(MAKE) check |
- | |
49 | endif |
- | |
50 | 47 | ||
51 | touch build-stamp |
48 | touch build-stamp |
52 | 49 | ||
53 | clean: |
50 | clean: |
54 | dh_testdir |
51 | dh_testdir |
55 | dh_testroot |
52 | dh_testroot |
56 | rm -f build-stamp |
53 | rm -f build-stamp |
57 | 54 | ||
58 | # Add here commands to clean up after the build process. |
55 | # Add here commands to clean up after the build process. |
59 | [ ! -f Makefile ] || $(MAKE) distclean |
56 | [ ! -f Makefile ] || $(MAKE) distclean |
60 | dh_autoreconf_clean |
57 | dh_autoreconf_clean |
61 | dh_clean |
58 | dh_clean |
62 | [ -d src/nettle -a ! -d src/nettle-dontuse ] || mv src/nettle-dontuse src/nettle |
59 | [ -d src/nettle -a ! -d src/nettle-dontuse ] || mv src/nettle-dontuse src/nettle |
63 | 60 | ||
64 | install: build |
61 | install: build |
65 | dh_testdir |
62 | dh_testdir |
66 | dh_testroot |
63 | dh_testroot |
67 | dh_clean -k |
64 | dh_clean -k |
68 | dh_installdirs |
65 | dh_installdirs |
69 | 66 | ||
70 | # Add here commands to install the package into debian/tmp |
67 | # Add here commands to install the package into debian/tmp |
71 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
68 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
72 | 69 | ||
73 | build-indep build-arch: build |
70 | build-indep build-arch: build |
74 | 71 | ||
75 | # Build architecture-independent files here. |
72 | # Build architecture-independent files here. |
76 | binary-indep: build-indep install |
73 | binary-indep: build-indep install |
77 | dh_testdir |
74 | dh_testdir |
78 | dh_testroot |
75 | dh_testroot |
79 | dh_install -i --sourcedir=debian/tmp |
76 | dh_install -i --sourcedir=debian/tmp |
80 | dh_link -i |
77 | dh_link -i |
81 | dh_installchangelogs -i ChangeLog |
78 | dh_installchangelogs -i ChangeLog |
82 | dh_installdocs -i -A README |
79 | dh_installdocs -i -A README |
83 | dh_installinfo -i |
80 | dh_installinfo -i |
84 | dh_installman -i |
81 | dh_installman -i |
85 | dh_installdebconf -i |
82 | dh_installdebconf -i |
86 | dh_compress -i |
83 | dh_compress -i |
87 | dh_fixperms -i |
84 | dh_fixperms -i |
88 | dh_makeshlibs -i |
85 | dh_makeshlibs -i |
89 | dh_installdeb -i |
86 | dh_installdeb -i |
90 | dh_shlibdeps -i |
87 | dh_shlibdeps -i |
91 | dh_gencontrol -i |
88 | dh_gencontrol -i |
92 | dh_md5sums -i |
89 | dh_md5sums -i |
93 | dh_builddeb -i |
90 | dh_builddeb -i |
94 | 91 | ||
95 | # Build architecture-dependent files here. |
92 | # Build architecture-dependent files here. |
96 | binary-arch: build-arch install |
93 | binary-arch: build-arch install |
97 | dh_testdir |
94 | dh_testdir |
98 | dh_testroot |
95 | dh_testroot |
99 | dh_install -a --sourcedir=debian/tmp |
96 | dh_install -a --sourcedir=debian/tmp |
100 | dh_link -a |
97 | dh_link -a |
101 | dh_installchangelogs -a ChangeLog |
98 | dh_installchangelogs -a ChangeLog |
102 | dh_installdocs -a -A README |
99 | dh_installdocs -a -A README |
103 | dh_installexamples -a |
100 | dh_installexamples -a |
104 | dh_installman -a |
101 | dh_installman -a |
105 | dh_installinit -a |
102 | dh_installinit -a |
106 | dh_installdebconf -a |
103 | dh_installdebconf -a |
107 | dh_strip -a |
104 | dh_strip -a |
108 | dh_compress -a |
105 | dh_compress -a |
109 | dh_fixperms -a |
106 | dh_fixperms -a |
110 | dh_makeshlibs -a |
107 | dh_makeshlibs -a |
111 | dh_installdeb -a |
108 | dh_installdeb -a |
112 | dh_shlibdeps -a |
109 | dh_shlibdeps -a |
113 | dh_gencontrol -a |
110 | dh_gencontrol -a |
114 | dh_md5sums -a |
111 | dh_md5sums -a |
115 | dh_builddeb -a |
112 | dh_builddeb -a |
116 | 113 | ||
117 | binary: binary-arch binary-indep |
114 | binary: binary-arch binary-indep |
118 | .PHONY: build-indep build-arch build clean clean-patched binary-indep binary-arch binary install |
115 | .PHONY: build-indep build-arch build clean clean-patched binary-indep binary-arch binary install |