Rev 8 | Rev 26 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
2 | |||
3 | include /usr/share/cdbs/1/class/autotools.mk |
||
4 | include /usr/share/cdbs/1/rules/debhelper.mk |
||
8 | magnus | 5 | include /usr/share/cdbs/1/rules/dpatch.mk |
2 | magnus | 6 | |
7 | # the used configure parameters for ./configure |
||
8 | DEB_CONFIGURE_EXTRA_FLAGS := --enable-pam --enable-kerberos --enable-srp \ |
||
9 | --with-pty --enable-tcp-forward --enable-x11-forward \ |
||
10 | --enable-agent-forward --enable-ipv6 --enable-utmp \ |
||
11 | --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \ |
||
12 | --with-x XAUTH_PROGRAM=/usr/bin/xauth |
||
13 | |||
8 | magnus | 14 | DEB_INSTALL_CHANGELOGS_ALL := ChangeLog |
15 | DEB_INSTALL_DOCS_ALL := README |
||
16 | DEB_DH_INSTALL_SOURCEDIR := debian/tmp |
||
2 | magnus | 17 | |
25 | magnus | 18 | LDFLAGS += -Wl,--as-needed -Wl,--no-undefined |
2 | magnus | 19 | |
8 | magnus | 20 | common-install-arch:: |
2 | magnus | 21 | install -m755 debian/scripts/lsh-server-config \ |
8 | magnus | 22 | debian/tmp/usr/sbin |