Rev 83 | Rev 86 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
79 | magnus | 2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
||
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
||
2 | magnus | 5 | |
79 | magnus | 6 | # Uncomment this to turn on verbose mode. |
7 | #export DH_VERBOSE=1 |
||
2 | magnus | 8 | |
79 | magnus | 9 | # These are used for cross-compiling and for saving the configure script |
10 | # from having to guess our platform (since we know it already) |
||
11 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
||
12 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
||
2 | magnus | 13 | |
79 | magnus | 14 | ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) |
15 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) |
||
16 | else |
||
17 | buildflags = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
||
18 | endif |
||
2 | magnus | 19 | |
79 | magnus | 20 | parallel = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) |
21 | ifneq (,$(parallel)) |
||
22 | jobsflag = -j$(parallel) |
||
23 | endif |
||
24 | |||
25 | config.status: configure.ac |
||
26 | dh_testdir |
||
27 | # Add here commands to configure the package. |
||
28 | [ -d src/nettle-dontuse -a ! -d src/nettle ] || mv src/nettle src/nettle-dontuse |
||
29 | dh_autoreconf |
||
30 | ./configure $(buildflags) \ |
||
31 | --prefix=/usr \ |
||
32 | --disable-dependency-tracking \ |
||
33 | --enable-pam --enable-kerberos --enable-srp \ |
||
34 | --with-pty --enable-tcp-forward --enable-x11-forward \ |
||
35 | --enable-agent-forward --enable-ipv6 --enable-utmp \ |
||
36 | --with-zlib --with-tcpwrappers --with-sshd1=/usr/sbin/sshd \ |
||
37 | --with-x XAUTH_PROGRAM=/usr/bin/xauth \ |
||
38 | CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS) -Wl,-z,defs -Wl,--as-needed" |
||
39 | |||
40 | build: build-stamp |
||
41 | build-stamp: config.status |
||
42 | dh_testdir |
||
43 | |||
44 | # Add here commands to compile the package. |
||
45 | $(MAKE) $(jobsflag) MAKEINFO='makeinfo --enable-encoding' |
||
85 | magnus | 46 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
47 | $(MAKE) check |
||
48 | endif |
||
79 | magnus | 49 | |
50 | touch build-stamp |
||
51 | |||
52 | clean: |
||
53 | dh_testdir |
||
54 | dh_testroot |
||
55 | rm -f build-stamp |
||
56 | |||
57 | # Add here commands to clean up after the build process. |
||
58 | [ ! -f Makefile ] || $(MAKE) distclean |
||
59 | dh_autoreconf_clean |
||
60 | dh_clean |
||
61 | [ -d src/nettle -a ! -d src/nettle-dontuse ] || mv src/nettle-dontuse src/nettle |
||
62 | |||
63 | install: build |
||
64 | dh_testdir |
||
65 | dh_testroot |
||
66 | dh_clean -k |
||
67 | dh_installdirs |
||
68 | |||
69 | # Add here commands to install the package into debian/tmp |
||
70 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
||
71 | |||
72 | build-indep build-arch: build |
||
73 | |||
74 | # Build architecture-independent files here. |
||
75 | binary-indep: build-indep install |
||
76 | dh_testdir |
||
77 | dh_testroot |
||
78 | dh_install -i --sourcedir=debian/tmp |
||
79 | dh_link -i |
||
80 | dh_installchangelogs -i ChangeLog |
||
81 | dh_installdocs -i -A README |
||
82 | dh_installinfo -i |
||
83 | dh_installman -i |
||
84 | dh_installdebconf -i |
||
85 | dh_compress -i |
||
86 | dh_fixperms -i |
||
87 | dh_makeshlibs -i |
||
88 | dh_installdeb -i |
||
89 | dh_shlibdeps -i |
||
90 | dh_gencontrol -i |
||
91 | dh_md5sums -i |
||
92 | dh_builddeb -i |
||
93 | |||
94 | # Build architecture-dependent files here. |
||
95 | binary-arch: build-arch install |
||
96 | dh_testdir |
||
97 | dh_testroot |
||
98 | dh_install -a --sourcedir=debian/tmp |
||
99 | dh_link -a |
||
100 | dh_installchangelogs -a ChangeLog |
||
101 | dh_installdocs -a -A README |
||
102 | dh_installexamples -a |
||
103 | dh_installman -a |
||
104 | dh_installinit -a |
||
105 | dh_installdebconf -a |
||
106 | dh_strip -a |
||
107 | dh_compress -a |
||
108 | dh_fixperms -a |
||
109 | dh_makeshlibs -a |
||
110 | dh_installdeb -a |
||
111 | dh_shlibdeps -a |
||
112 | dh_gencontrol -a |
||
113 | dh_md5sums -a |
||
114 | dh_builddeb -a |
||
115 | |||
116 | binary: binary-arch binary-indep |
||
117 | .PHONY: build-indep build-arch build clean clean-patched binary-indep binary-arch binary install |